みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

社内ネットワーク障害原因

こんにちは。
1つ教えてください。

LANケーブルのコネクタを作り変えて、HUB3に接続したところ
1階の全てのパソコンがネットに繋がらなくなってしまいました。
HUB2を延長コネクタでLANケーブルを繋ぎ、HUB2を使用しなくしたら
解消しました。

サーバー⇒元HUBよりHUB1

HUB1よりHUB2
HUB2よりHUB3

HUB1よりHUB4
HUB1よりHUB5
という接続ですが
HUB4,HUB5に接続してあるパソコン全てが繋がらなくなりました。

ループとも思えないのですが
他に考えられることがあるでしょうか?

わかる方おられましたら、教えて頂けないでしょうか?
宜しくお願いします。

投稿日時 - 2017-10-21 10:48:42

QNo.9388240

困ってます

質問者が選んだベストアンサー

HUB2、HUB3ともスイッチングハブだとしても、
HUB2の対向側のHUB1がリピータハブだとしたら、そのせいで多段制限を受けてたってこと
じゃないですかね。
それと、よく読んだらサーバー接続までは、間にもうひとつHUBを
経由しているということなので、これもリピータハブになってるとか。


それと、アライドテレシス社のFS709ってことですが、
これ15年以上前の 10BASE-T/100BASE_TX自動認識タイプのスイッチングハブなんですね。
これにCate6ケーブル(もしかしてシールド付き?)を接続したら
スイッチングハブ側のポートはシールドに対応していないので、
返ってノイズの影響を受けやすくなって、
結果10BASE-Tと認識してしまったのかもしれませんね。
(Cate5eのシールドなしケーブルに交換したことで、100BASE-TXになったとか?)
実機で検証してみないと なんとも言えませんが、可能性として。

投稿日時 - 2017-10-22 12:10:58

お礼

本当に何度もありがとうございます。
非常に分かりやすい回答で、感謝いたします。

特に古いHUBを仮で使用する時は要注意や
いろいろ勉強になりました。

ありがとうございました。

投稿日時 - 2017-10-22 12:56:53

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(8)

ANo.7

> 1日間は何ともなく、HUB3からPCへのLANケーブルを
> 交換したら障害が発生したのですが
> 考えた原因でおかしいのはありますか?

情報が小出しで、しかもやったこととそのときの症状が時系列で整理されていないと
原因の特定は不可能です。

整理すると、
HUB1-HUB2の先にHUB3を追加設置して
PC-HUB1-HUB2-HUB3-PC と接続したところ、直後は障害はなかったってことなんですね。
ならば、アップリンクポートの誤接続やループ発生の問題は除外できます。

また、なにも変更したわけでもないのに1日後に障害が出たということでなく、
PC-HUB1-HUB2-HUB3-PC のケーブルのうちのHUB3-PC間のケーブル交換したときに
障害がでたってことならは、不正なDHCPサーバーを設置してしまった
というのも除外できます。

HUB3-PC間のケーブル交換後に 障害がでたが
PC-HUB1-HUB2-HUB3-PCのHUB2を取っ払って、PC-HUB1-HUB3-PCに
したら復旧したってことでよろしいですか?
ということなら、一番に疑えるのは、
 ・スイッチングハブでなく、リピータハブを使っている
  (リピータハブの場合、ハブの多段接続は、10BASE-Tなら4段まで、
   100BASE-TXなら2段までの制限あり)
 ・HUB3-PC間のケーブル交換で10BASE-Tから100BASE-TXに変わった
という現象です。
つまり、
PC-HUB1-HUB2-HUB3-PC の状態だと通過するリピータハブは3段であるが
10BASE-Tのときなら問題なくても、100BASE-TXのケーブルに交換されたことで、
通信障害がでた。
しかし、HUB2をとっぱらって
PC-HUB1---<メスメスコネクタで直結>----HUB3-PC に変更したことで、
通過するリピータハブが減ったので、100BASE-TXでも 通信ができるようになった
ということならで、説明がつきますね。

投稿日時 - 2017-10-21 23:39:37

お礼

大変丁寧で分かりやすい回答を頂きありがとうございます。
確かに行った作業はsuperside0さんの書かれた通りです。
調べていましたら2段や4段の事が分かりました。
交換したLANケーブルは長さの問題で6から5eの線に交換しました。
現場をもう一度確認してみますが、今までが10BASEの可能性も
あったという事でしょうか?
元のHUB2はバッファロー社ので、ホームページにスイッチングハブとなっていました。
HUB3はアライドテレシス社のFS709になりますが
これがリピータハブになるのでしょうか?
情報が小出しで申し訳ありません。

投稿日時 - 2017-10-22 09:48:00

ANo.6

> HUB3は新たに設置したのですが、元々はHUB2から無線ルーターに繋がっていた線を
> HUB3に差し替え、HUB3から無線ルーターに繋ぐようにしました。

>それとHUB2からパソコン2台繋いでいましたが
>そのパソコン2台はHUB3から繋ぐようにしましたので
>HUB2に不要なLANケーブルを2本差したままにしておきましたが
>その2点は影響はないでしょうか?

その2点で 異状な接続を起こしていたのであれば
影響はありますし、そうでないのなら関係ありません。

例えば、昔のリピーターハブだと10BASE-Tで4段、100BASE-TXなら2段までしか、
多段接続できませんでした。
今時のスイッチンブハブなら、この制限はありません。

投稿日時 - 2017-10-21 21:13:02

お礼

何度もありがとうございます。
延長コネクタで繋いだら障害は解消したのですが
原因がいまいちハッキリせずすいません。

考えられる原因ですが
1.アップリンクポートに元線を差し込まなかった。
2.HUB2に未使用線を差したままにした為、記憶されているMACアドレスのPCが見つからなかった為ループ現象が発生。
3.無線ルーターの設定がブリッジモードでループ現象が発生。
4.手製のLANケーブルの接触不良でループ現象が発生。

1日間は何ともなく、HUB3からPCへのLANケーブルを
交換したら障害が発生したのですが
考えた原因でおかしいのはありますか?

投稿日時 - 2017-10-21 21:55:30

ANo.5

> アップリンクポートにパソコンを
> それ以外に元からの線を繋ぐと
> ループしてしまうのでしょうか?

この場合は、ループとは違います。

ただ、HUBの機能や性能によっても変わりますが、
アップリンクポートにストレートケーブルでPCを接続したといった逆相の接続をすると
TX信号のコンフリクトと、RX信号のフローティングがおきて
そのHUBの全ポートの通信に影響して通信が止まってしまうことはあり得るでしょう。
今時のスイッチングハブやL3スイッチでなく、昔のいわゆる”バカハブ”なら
そうなる可能性は高いと思います。

なお、これと、ループしてブロードキャストフレームが起きてしまった場合とは
影響範囲や症状が異なります。

投稿日時 - 2017-10-21 19:22:50

お礼

回答ありがとうございます。
なるほどよくわかりました。
大変申し訳ありません、もう少しお聞きしたいのですが
HUB3は新たに設置したのですが、元々はHUB2から無線ルーターに繋がっていた線をHUB3に差し替え、HUB3から無線ルーターに繋ぐようにしました。

それとHUB2からパソコン2台繋いでいましたが
そのパソコン2台はHUB3から繋ぐようにしましたので
HUB2に不要なLANケーブルを2本差したままにしておきましたが
その2点は影響はないでしょうか?

投稿日時 - 2017-10-21 20:44:56

ANo.4

> LANケーブルのコネクタを作り変えて、HUB3に接続したところ
> 1階の全てのパソコンがネットに繋がらなくなってしまいました。
>HUB2を延長コネクタでLANケーブルを繋ぎ、HUB2を使用しなくしたら
>解消しました。

これだけ聞くと、 
オートMDI/MDI-X機能や、アップリンクポート(カスケード)のない古いHUBだと
HUB間はクロスケーブルでないといけないのに、間違ってストレートケーブルを
使ってしまって、その結果、通信が停止してしまったが、
HUB1-HUB2-HUB3 のHUB2を使わずに、メスメスのLAN延長コネクタを使って
HUB1-HUB3間を直結したら HUB3がオートMDI/MDI-Xなので解決した
というように見えます。

ただ、後からの補足を見ると、ケーブル交換して直後に通信できなくなったのではなく、
ケーブル交換に加えて、新しくHUBを設置して、そのHUBに新しくネットワーク機器を接続したところ1日程度の時間がたってNGになったということのようなので、
その新規の機器のせいでIPアドレス衝突とか、IPアドレスの間違いが起きているとか
異状パケットが出ているとか、ではないでしょうか。

例えば、新規のHUBが時間が立つと熱暴走してしまっているとか、

もしくは、 Wi-Fiのアクセスポイントを既存LANに新規設置したが、
Wi-Fiルータをブリッジモードでなく誤ってルータモードで設置してしまい、
その結果、LAN内に,不正なDHCPサーバーが存在することになって
DHCPクライアントであるLAN内のPCが(朝の起動のタイミングとかで)
その不正なDHCPサーバーから新しくIPアドレスを降り出してもらうタイミングで、
IPアドレスやデフォルトゲートウェアが、本来のものでなくなって
通信異状がおきてしまっているとか。

ただ、それならHUB2をとっぱらって HUB1ーHUB3間を直結にしたら解決したというのとはつじつまがあいませんけれども、
2つの現象(クロスケーブル間違いと不正DHCPサーバー設置)の2つが
どちらも発生しているということもあり得ますね。

投稿日時 - 2017-10-21 14:59:06

お礼

大変丁寧な回答ありがとうございます。
もう1度お聞きしたいのですが
アップリンクポートにパソコンを
それ以外に元からの線を繋ぐと
ループしてしまうのでしょうか?
ケーブルは全てストレートです。

どうぞ宜しくお願いします。

投稿日時 - 2017-10-21 17:06:13

ANo.3

ケーブルをつくりかえたら繋がらなくなったということであれば、ケーブルの作成ミスとなるわけですが。
ケーブルのチェックはされていますか?

また、HUBに関しても、アップリンクをもっているHUBもまだありますし、UPリンクをもっていないHUBもあります。

UPリンクを持っていないHUBで上位のHUBと接続する場合は、クロスケーブルをつかななければなりません。
自動判定してくれるHUBが増えていますが、できないHUBも今現在でも結構使われています。

その辺は確認されていますでしょうか?

投稿日時 - 2017-10-21 12:01:53

補足

追記になりますが

HUB3で1番がカスケードポート仕様になっていて
HUB2からの線を1番にパソコンを2~8番に繋ぐのが正解でしょうが
HUB2からの線を8番にパソコンを1番から繋いだらどうなるのでしょうか?

今回のような現象が起きますか?

投稿日時 - 2017-10-21 14:17:56

お礼

回答ありがとうございます。
作り直したケーブルはテスターでチェックし、別のPCで疎通の確認をして使用しました。

HUB3を配置し配線し1日は問題ありませんでしたし、LANケーブルを変えても
30分は問題ありませんでした。

ループのような配線ではないと思うのですが
ループのような現象になりました。

どのような原因でしょうか?

投稿日時 - 2017-10-21 13:24:10

ANo.2

元々正常であったものに
雄のコネクターを作り直した、これは何かで確認しましたか
簡単で有れば2.3の間の不具合、2~3の3側をハブから外してPCで使えるか確認

2側から3に至る2も抜いてみる
と言う線番チェック、または圧縮時他の線と短絡かも

2のハブの本体メス側を覗いてピンの確認
3のハブを2へ持ってくる一時交換
バイパスをした電線は既存の線でしょうか
それとも、今回作成した線でしょうか
いずれも、作業によって起きたと思いますが

投稿日時 - 2017-10-21 11:51:56

補足

追記になりますが

HUB3で1番がカスケードポート仕様になっていて
HUB2からの線を1番にパソコンを2~8番に繋ぐのが正解でしょうが
HUB2からの線を8番にパソコンを1番から繋いだらどうなるのでしょうか?

今回のような現象が起きますか?

投稿日時 - 2017-10-21 14:21:16

お礼

回答ありがとうございます。

コネクターを作り直した線はテスターでテストし
別のPCで疎通の確認をし付け変えました。

2から3への線は既存の線です。
何らかの理由があると思うのですが
ループするような配線ではないのに
ループのような現象が起こるのでしょうか?

投稿日時 - 2017-10-21 13:16:53

ANo.1

LANケーブルのコネクタを作り変えた時に作成を間違ったのでは?
なお、「HUB2を延長コネクタでLANケーブルを繋ぎ、HUB2を使用しなくしたら解消しました。」とのことですが、その意味は不明です。

投稿日時 - 2017-10-21 11:49:07

お礼

回答ありがとうございます。

LANケーブルの作成はLANケーブルテスターでテストし
別のパソコンで接続は確認し付け変えました。
HUB2を延長コネクタでとは、LANケーブルとLANケーブルを
直接繋ぐ延長コネクタの事です。

ループするような配線ではないのですが
1階全てでしたので、ループのような現象です。

投稿日時 - 2017-10-21 13:09:59

あなたにオススメの質問