みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

もう一度Eclipseのインストール方法を。

色々な意見をどうも有難うございます。

私は、頭の中が混乱状態になりました。

もう一度、最初からもう一度Eclipseのインストール方法を

教えて頂きたいのです。

お忙しいのに恐れ入ります。

お手数掛けます。

ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-08-04 11:18:17

QNo.9359196

すぐに回答ほしいです

質問者が選んだベストアンサー

>>「root」ユーザでログインして、コピペしてみて下さい。

>コピペできないのです。
>パーミッションが許してくれないのです。
>ご回答誠にありがとうございました。

Linux系OSは良く知りませんが
「root」ユーザは最高の権限のハズです。
(パーミッションではなくロックされてるのかもしれません)とりあえず再起動してコピペしてみて下さい。

投稿日時 - 2017-08-04 18:25:28

お礼

ご回答誠にありがとうございました。

お陰様でコピーには成功しました。

デモ、まだ日本語化されていません。

もう少しやってみます。

投稿日時 - 2017-08-04 19:08:55

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(9)

ANo.9

>Eclipseを起動すると、「error500」と出てきます。
当方では「error500」というエラーは出ませんが /etc/eclispe.ini へ追記しないときは英語版で起動します。

>貼り付け方が解りません。
/etc/eclispe.ini への追記については「端末」からスーパーユーザーでテキストエディターを使わないといけません。
回答No.7の参考URLではgeditを使うような説明ですが、セキュリティの関係でGUIモードのテキストエディターは使えませんので、viまたはnanoを使って最後の行へ追記します。

他の方法としては eclipse を apt-get コマンドでインストールし、プラグインの Babel を追加導入することで対応できます。

投稿日時 - 2017-08-07 18:58:15

お礼

Windows10でやりますので、それでも不都合が出てきたら

Ubuntuでやってみようかな。と思います。

ご回答誠にありがとうございました。

投稿日時 - 2017-08-07 19:48:28

ANo.8

>チョット参考URLが古くないですか?
最新のeclipseのバージョンは4.7のようですが1つ前の3.8をUbuntu 17.04にインストールできます。
「端末」を起動して次のコマンドを実行すればeclipseもインストールされます。
~/$ sudo apt-get install pleiades
eclipseのインストール先は/usr/share/applicationsになりますので、その実行ファイルをランチャーへドラックすればランチャーのアイコンをクリックして開くことができます。
尚、eclipse 4.7はapt-getコマンドに対応していないのではないかと思います。
日本語化のモジュールはWindows版を応用していると思いますので動作環境を定義しているeclipse.iniの記述方法を模索している段階ではないでしょうか?
従って、Linux用のeclipseは英語版は完成していて、日本語化のモジュールは未完成と思います。(Linux用のeclipseは安定的に使用できるバージョンが3.8と思います)

投稿日時 - 2017-08-05 21:56:54

補足

Eclipseを起動すると、「error500」と出てきます。

-javaagent:/usr/lib/eclipse/plugins/jp.sourceforge.mergedoc.pleiades/pleiades.jar

が貼り付け方が解りません。

すみません。

モウ1度、ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-08-07 15:42:44

お礼

今は疲れてます。

休んでからやってみます。

投稿日時 - 2017-08-06 20:08:48

ANo.7

>Ubuntuも英語版は出来ているけど何かいいアドバイスがあれば
参考URLを読んでみることをお薦めします。(Pleiadesとは異なるプラグインの導入のようです)
但し、JAVAはツール(プログラム)のモジュールを作成するためのプログラム開発言語と言う使い方になります。
若し、Java Scriptと混同しているのであれば不要な環境になります。

参考URL:https://wiki.ubuntulinux.jp/UbuntuTips/Application/EclipseJapaneseSetup

投稿日時 - 2017-08-05 16:38:31

お礼

すみません。
チョット参考URLが古くないですか?

全然参考URL通りになっていませんでした。

投稿日時 - 2017-08-05 20:12:33

ANo.6

>「eclipse.ini」の変更をしたのですが、
>日本語にならず。

おそらく-javaagentの指定を間違ってるんでしょうけど。
そんなに早く諦めて大丈夫ですか?
javaの習得やwebサーバーの開発はeclipseの日本語化以上に難解ですよ。

投稿日時 - 2017-08-05 01:17:02

お礼

Windowsで出来たから一応いいと思っています。

Ubuntuも英語版は出来ているけど何かいいアドバイスがあれば

宜しくお願い申し上げます。

投稿日時 - 2017-08-05 01:39:45

ANo.5

>お陰様でコピーには成功しました。
>デモ、まだ日本語化されていません。

「eclipse.ini」の変更ですね。

投稿日時 - 2017-08-04 22:15:18

お礼

「eclipse.ini」の変更をしたのですが、

日本語にならず。

もう諦めて、Windowsマシンで日本語化になりました。

色々とありがとうございました。

投稿日時 - 2017-08-04 22:52:51

ANo.4

>回答No.3 amanojaku1

>「root」ユーザは最高の権限のハズです。
>(パーミッションではなくロックされてるのかもしれません)とりあえず再起動してコピペしてみて下さい。

Eclipseを起動すると そこがロックされてしまうのかもしれないので、Eclipseを起動する前にコピペしてみて下さい。

投稿日時 - 2017-08-04 19:01:53

お礼

コピペされる方とする方はどれでしたでしょうか?

すみません。

忘れてしまいました。

ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-08-11 16:21:17

ANo.2

>このディレクトリに上書きするんだよ☆
>コレのパーミッションがきつくてどうしても
>上書きできません。

Linux系OSは良く知りませんが
「root」ユーザでログインして、コピペしてみて下さい。

ちなみに、下記は日本語化プラグイン同梱Eclipseです。
最新のバージョンより1つ前ぐらいのバージョンの方が安定してます。

Pleiades - Eclipse プラグイン日本語化プラグイン
http://mergedoc.osdn.jp/

投稿日時 - 2017-08-04 16:34:56

お礼

「root」ユーザでログインして、コピペしてみて下さい。

コピペできないのです。

パーミッションが許してくれないのです。

ご回答誠にありがとうございました。

投稿日時 - 2017-08-04 17:37:10

ANo.1

チャントOSとかサーバー・サイドの開発とか書いたほうが良いですよ。

https://okwave.jp/qa/q9357423.html

>ボクはwebサーバ用のを作りたいので

Linux系OSは良く知りませんが
サーバー・サイドの開発をしたいのなら、恐らくLinuxのサーバ化が必要です。

サーバーソフトウェアのインストール
http://debianj.com/ubuntu/install

↑色々書いてありますが「Apache HTTP Server」がサーバー化の肝です、他は どうでも良いです

The Apache HTTP Server Project
https://httpd.apache.org/

↑「Apache httpd 2.4.x」よりも、前の「Apache httpd 2.2.x」の方が安定してます。
当然「Apache HTTP Server」の設定が必要です。

あと、確かサーバー・サイドJavaを開発したい場合は「Java Platform, Enterprise Edition(Java EE)」が必要だったと思われます(OpenJDKは「Java Platform, Enterprise Edition(Java EE)」に対応していないかもしれません)。

Java EE(Enterprise Edition) 7 SDK Downloads
http://www.oracle.com/technetwork/java/javaee/downloads/index.html

↑「Java 8」ではなく「Java 7」であることに注意して下さい、「Java EE(Enterprise Edition) 」でググると「Java EE(Enterprise Edition) 7 SDK」しかヒットしません。

>Eclipseのインストールはできましたが、
>日本語化が全然解りません。

【Ubuntu】Eclipseをインストールする&日本語環境にする
http://www.milkmemo.com/entry/eclipse_install_japanese

Ubuntu 16.04 に Eclipse をインストールして日本語化したのでメモ
http://sicklylife.hatenablog.com/entry/2016/05/06/141928

Ubuntu 16.04 eclipse neonのインストールと日本語化
http://symfoware.blog68.fc2.com/blog-entry-1913.html

そう言えば、下記は日本語化プラグイン同梱です。
最新のバージョンより1つ前ぐらいのバージョンの方が安定してます。

Pleiades - Eclipse プラグイン日本語化プラグイン
http://mergedoc.osdn.jp/

投稿日時 - 2017-08-04 14:16:09

補足

このディレクトリに上書きするんだよ☆

コレのパーミッションがきつくてどうしても

上書きできません。

どうやって上書きするのか教えてください。

お忙しい中すいません。

ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-08-04 14:46:55

お礼

コピペされる方とする方はどれでしたでしょうか?

すみません。

忘れてしまいました。

ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-08-11 16:21:56

あなたにオススメの質問