みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

スマホの無線Lan接続が遅いです

環境は以下の通りです。
NEC製BX810II(ケーブルモデム) Yamaha製NVR500(ルーター) Buffalo製WZR-450HP(無線LANルター)ケーブルモデムにルーターを接続して、ルーターのLANポートにBuffaloの無線ルーターをブリッジ接続で接続しています。

Yamaha製NVR500(ルーター)はDHCP無効にしています。有線・無線のパソコンはすべて手動で固定IPアドレスを設定しています。

ノートパソコンを無線接続にして、問題なく接続できます。しかしスマホ(アンドロイド)は接続はされるのですが、ページの表示速度が異常に遅いです。1台のスマホだけでなく、10台程度のスマホすべてが同現象です。スマホのWI-FI設定を確認すると、電波強度は強になっています。

Yamaha製NVR500(ルーター)を外して、NEC製BX810II(ケーブルモデム)にBuffalo製WZR-450HP(無線LANルター)をローカルルーターモードにして設定するとスマホは無線LAN接続で快適に表示されます。

Yamaha製NVR500(ルーター)は業務上使用する必要があるため、使用する必要があります。無線接続のパソコンは問題なく動作するのに、スマホ(アンドロイド)はすべてインターネットページの表示が異常に遅いです。何が原因でしょうか。

よろしくお願いします。

投稿日時 - 2014-12-17 18:51:19

QNo.8861622

すぐに回答ほしいです

質問者が選んだベストアンサー

>NVR500はDHCP無効になっているため、WZR-450HPはローカルルーターモードにしてもネット接続できません。(二重ルーターになるのも心配ですが)

「ネット接続できません」ではなくて「ネット接続できる設定をしていません」の間違いでは?
DHCPが無効になってるなら手動で設定すればいいだけですし。

とりあえずNVR500(ルーター)+Aterm WG1400HPという組み合わせでノート,スマフォ共に遅いと思った事はないですけど。

投稿日時 - 2014-12-18 23:06:08

お礼

ご回答いただき、ありがとうございます。
ご指摘の通り、ネット接続できる設定をしておりません。正確にはネット接続できるようにする設定方法がわかりません。

いづれにせよ、解決しました。NVR500を介している場合、スマートフォーンはGoogle Public DNSを使用することで解決です。NVR500のIPアドレスをDNS1に設定していたため、ネット接続はするのですがページの表示が異常に遅くて困っていました。

パソコンの無線LANの場合、DNSはNVR500のIPアドレスで問題ないのですが、スマートフォーンの場合、同じ設定ではだめだったんです。NVR500の環境に依存する設定が必要だったんですね。

ちなみにNVR管理者も原因がわからないため、回答をいただけませんでした。YAMAHAにも問い合わせましたが、未回答のまま自力で解決しました。

投稿日時 - 2014-12-19 17:25:34

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.5

No.3です。

>NVR500はDHCP無効になっているため、WZR-450HPはローカルルーターモードにしてもネット接続できません。(二重ルーターになるのも心配ですが)

ルーターモード時のInternet設定で、”手動設定”を選択して、IPアドレスを指定すれば、DHCP環境が無くてもルータ―モードで動作させることは可能ですよ。確かに二重ルータになりますが、動作を確認するだけなので、心配はないかと思います。

投稿日時 - 2014-12-19 08:55:24

お礼

ご回答ありがとうございます。 NVR500を介して、WZR-450HPをルーターモードにできれば、解決したかもしれません。

今回はNVR500の設定環境に依存するためか、Google Public DNSを設定することで解決しました。WZR-450HPだけでローカルルーターモードにすれば、Google Public DNSにしなくても普通に問題なく接続できていたのですが。

ありがとうございました。

投稿日時 - 2014-12-19 17:33:51

ANo.3

まず、ファームウエアは最新でしょうか。文面からNVR500に接続した時はブリッジモードで接続されているように見受けられますが、ルータモードでも遅いのでしょうか。

参考URL:http://buffalo.jp/download/driver/lan/wzr-450hp_fw-win.html

投稿日時 - 2014-12-18 14:02:55

お礼

ご回答ありがとうございます。

ファームウエアは未確認です。確認後、アップデートしてみます。
NVR500はDHCP無効になっているため、WZR-450HPはローカルルーターモードにしてもネット接続できません。(二重ルーターになるのも心配ですが)

NVR500を外して、WZR-450HPをローカルルーターモードで接続するとスマートフォーンは問題なく動作します。

他メーカーの無線LAN機器では試してませんので、同様の現象が発生するか確認してみます。もし同様の現象が発生するようであれば、NVR500側の設定の問題か、スマートフォーンの設定で何か足りてないのか、と言うことになると思います。

スマートフォーンはIPアドレス、デフォルトゲートウエイ、DNSを設定しています。IPアドレスは重複しないIPを設定、デフォルトゲートウエイ及びDNSはNVR500のIPアドレスを設定しています。

プロキシは立ててないはずですので、スマートフォーンでも設定はしていません。パソコンのウエブブラウザでもプロキシ設定はありませんでした。

原因究明のため、もう少し頑張ってみます。

投稿日時 - 2014-12-18 19:07:47

ANo.2

>>1台のスマホだけでなく、10台程度のスマホすべてが同現象です。スマホのWI-FI設定を確認すると、電波強度は強になっています。

10台も繋げは、速度は単純に考えて1/10以下になると思えるので、遅くなって当然ではないでしょうか?

投稿日時 - 2014-12-17 19:39:52

お礼

ご回答ありがとうございます。

10台同時に接続することはほとんどありません。1台のスマホで遅い現象を確認中、他のスマホは使用しないでテストしました。

YAMAHAのルーターを介すか、介さないかでスマホのネット接続速度が違います。YAMAHAルータ側でパソコンのパケットは優先的に通すけど、スマホからのパケットは後回しにするような設定でもしているのでしょうか。 

YAMAHAルーターは業務ソフトの提供業者が管理しているので、触ることができません。一応、管理者に聞いてみます。

ありがとうございます。

投稿日時 - 2014-12-17 21:20:44

あなたにオススメの質問