みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

LinuxにSkypをダウンロードしたい

Linux Ubuntu12.04でSkypのサイトからLinuxバージョンをインストールしましたが「依存関係が満たされていません:libgtweb kit(>=2.2k~2011week36)」のメッセージが表示され、インストールが完了しません。成功させる方法をおしえてください。尚、Partnerリポジトリを有効にする必要があると参考資料にありましたが操作方法が分かりません。

投稿日時 - 2014-08-27 20:00:47

QNo.8732717

困ってます

このQ&Aは役に立ちましたか?

14人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

以下の「Skypeのダウンロードとインストール - Ubuntu」を参照して下さい。

https://support.skype.com/ja/faq/FA12120/

投稿日時 - 2014-08-28 09:50:06

お礼

ごく初歩的なミスでした。アップデイトの詳細設定でプログラムのダウンロードの許可にチェックが入っていなかった事が原因でした。御手数をおかけしましたが無事インストール完了です。有難うございました。

投稿日時 - 2014-09-03 08:54:20

ANo.1

UbuntuなどのDebian GNU/Linux系のLinux系OSではapt
FedoraやCentOSなどのRedHat系のLinux系OSではyumといった
パッケージ管理のシステムが採用されているのが普通です。

Ubuntuの場合(Xubuntu,Xubuntuなども同様)は、debパッケージ形式
そのパッケージを扱うdpkgコマンド
パッケージをリポジトリーに集約し、それを利用するapt
関連するaptitudeコマンドやapt-get,apt-cacheコマンドなど
そして、GUI版のソフトウェアセンターやSynapticなどが利用されます。

これらの枠組みによって、21世紀に入ったころから
Linux系OSでは、依存関係や競合の問題は
手軽に解消され、意識する機会も少なくなりました。
(まずダウンロード先を探す手間が、激減したことを知らない人も少なくありませんが…)


ですから、基本的にはリポジトリーにあるSkypeを導入するのが手軽です。


ただし、リポジトリーにはそのUbuntuのリリースにおいて
リリース時のバージョンのものが提供されるのが基本です。

セキュリティアップデートなどは反映されますが
新バージョンの新機能を利用できない状態が続くこともあります。


ただ、Linux版のSkypeは、開発が停滞しているので
特に問題になることは無いと思います。
ちなみに、うちの12.04LTS環境では、4.3.0.37が導入されています。

たぶん、依存関係があるライブラリーとして
libwebkitgtkなどが要求されるはずですが
自動的に、共にダウンロードされ導入されています。


通話テストは、普通に正常動作しますし
Pulseaudioを使って、音声の入力と出力を
内蔵音源,USB音源,Bluetooth等の間で切り替えながら使えますし
LAN転送で、別のLinuxPCのスピーカーなどを利用することもできます。


最新バージョンを導入したい場合は
手動で、依存関係を指摘されたパッケージを探します。
(この指摘は、debパッケージが持つ情報とdpkg等のツールによって表示されます)

基本的には、リポジトリーにあるパッケージを探します。
libgtwebkitというのは無いので
たぶんlibwebkitgtkでいいんじゃないかと思います。

ただ、同じライブラリー等でも
バージョン違いで、うまく動かないことはありえます。

そういった場合には、ライブラリー等も
リポジトリーではなく、別途Web上のどこかから探してきて
必要に応じて、自分でビルドしてインストールすることになります。
(Ubuntu14.04LTSで構築することを検討する手もあります)


一応、バージョンの違いが問題無く動く場合もあるので
依存関係を無視した強制インストールという手段もあります。
(推奨では無いので、その手順は割愛します)


WindowsではVista以降必須のソフトを動かすために
XPにVista以降の機能を追加するようなことはできないので
OSSの柔軟さが、そういった部分にあるといえばあります。

反面、その作業自体は煩雑で、難解な場合もあり
依存関係の連鎖で、迷路に迷い込むこともありえます。


ですから、個人的には、よほどのことがなければ
リポジトリーに無いものは使わないのが手軽だと考えています。

また、そういったライブラリーのバージョンの問題を複雑に捉えて
「Linux用の市販ソフトの開発は非常に困難だ」と論じる人もいます。

もっともAdobe FLASH PlayerやGoogle Chromeなどは
Linux版でライブラリーのバージョン問題にハマることは無いようですから
そういった問題は、この10年程度の間にも、ずいぶん改善されているようです。

投稿日時 - 2014-08-27 21:54:10

補足

問題の解決方法が良く分からないので操作方法を一から教えていただけると助かります。

投稿日時 - 2014-08-31 14:38:15

お礼

アップデイトの詳細設定でプログラムのダウンロードの許可にチェックが入っていなかった事が原因でした。御手数をおかけしましたが無事インストール完了です。有難うございました。

投稿日時 - 2014-09-03 08:54:14

あなたにオススメの質問