みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

現行マインクラフトでv1.5.2のMOD利用法は?

前置きが長くなりますが、つい先月末にPC版マインクラフトを購入したばかりです。
時期的にダウンロードしたバージョンは本体1.6.4、ランチャーが1.2.5で共に最新です。
もちろん最初はバニラ状態で楽しんでおりました。さすがに飽きてきたところマイクラmodの存在を知りましたが、1.6.4対応modがまだ少ないということで諦めていたのですが、どうやら一般ソフトのように一方通行なダウングレードをしなくても別途個別にoldバージョン環境を構築できると知り、安定modが豊富な1.5.2環境(フォルダ)を作りました。
作成法はランチャー側からの新規プロフィール作成で1.5.2を選び、一度バニラでタイトル画面まで起動してます。

多くのmodには前提modと呼ばれるものが必要だと知り、利用頻度の高そうなForgeに決定。
1.5.2対応の「minecraftforge-installer-1.5.2-7.8.1.737」を入れました。多くのサイトでは手動の導入法が記されてましたが
jarファイルによるインストーラ型も配布されていたのでそれを使ってインストール。この時点でマイクラフォルダ内にはバニラ1.6.4&1.5.3、1.5.3Forgeの3種類の環境ができました。

※余談ですが現行では「.minecraft」フォルダ下に「versions」というフォルダがあり、その中に作成した各バージョンのフォルダができます。
そのフォルダ内に「バージョン名.jar」「バージョン名.json」という2つのファイルが存在します。手動で書き換えを行わなくてもランチャー側のプロフィール作成機能で自動で作ってくれるようです。


続いて再度ランチャー側のプロフィール作成で、追加された1.5.3forgeを選択してプロフィール作成。
この作成の際のオプションで、セーブデータやMODフォルダもプロフィール別に個別作成できるので「.minecraft」フォルダ下に「1.5.3 forge」というフォルダを作り、そこをforgeを使うデータの保存先に指定しました。
さて1.5.3forgeのプロフィールでゲームを起動、タイトル画面に「mods」も追加されています。一応この時点でforgeまでの導入は成功しているのだと思います。


問題はその後なのです。
modサイトから1.5.3に対応したmodを探して幾つか保存。一応、Forge前提のものか、または無記載のものかのどちらかだけを選んでいます。
モノによるがZIPファイルのままmodsフォルダに入れるだけでいいと聞いていたのですが、そのとおりに前持って作成しておいた1.53forgeフォルダの中にあるmodsフォルダにzipファイルを投入してからゲーム起動しても、タイトルのmodsリスト欄には記載されてないし、ゲームにも何ら反映されておりません。何かのエラーログが出るとかそういうのもないです。

以上の情報から、MODの導入法に誤りがありますでしょうか? 
そして幾つか質問があるのですが、

-1, forge前提ではないmodだけは 「.minecraft」直下にあるmodsフォルダに入れるべきなのでしょうか?

-2, そうするとランチャーのプロフィールから起動する際の関係(保存フォルダの関係)でforge前提modと非対応modはどちらかしか選べない気がするのですが、
    そもそもforge前提modと非対応modというものは併用できるものなのでしょうか?

-3, 現行環境においての1.53利用ということですが、この場合でもmodの種類によってはmodsフォルダにzipを入れるだけじゃなく1.5.3.jarを開いてmodファイルを手動で入れるという行為も当然の如くあるのでしょうか?

-4, そもそもの1.5.3forge用保存フォルダを作成した場所が 「.minecraft\1.5.3forge」じゃダメだったとかで、あるサイトに記載されてたように「1.5.3forge\.minecraft」といったように末端フォルダを .minecraftに指定しないといけなかったりするんでしょうか? その関係かMIGICLAUNCHERというツールでforgeを使用する前提での設定がうまくいきませんでした。

最後に参考として、使用予定のmod名を羅列しておきます。
どれも1.5.2対応のもので、forge前提か、無記載、一部、必須前提modとセットのものです。

CastleDefenders(拠点警護兵隊NPC追加)、invasion_mod(大量の敵モブが襲ってくる)、 DrZharks MoCreatures(動物追加)&必須mod"CustomMobSpawner"と前提jar、millenaire(ワールド各地に種類豊富なNPC村ができる)、iPixeliGender(自キャラ女性化)、Jammy_Furniture(現代風家具追加)、竹mod(和風アイテム)、Basic Guns Mod(銃火器追加)、Minecraft3D beta(グラ向上)、mod_thx_helicopter(乗れるヘリ追加)、CustomNPCs(NPCのAIを賢くしてステ振り)、ColoredBlocks(バニラのブロックを色分け)

あたりです。場合によっては幾つか減らしても構いませんが最初の数個だけは是非とも同時使用を考えてます。長文になりましたが、宜しくお願いします。

投稿日時 - 2013-10-15 14:44:54

QNo.8306665

すぐに回答ほしいです

質問者が選んだベストアンサー

こんばんわ

Ver.1.5.2でModを複数入れている者です。
私はForgeをインストーラー&手動で
入れましたが、手動の方がやり直しも
楽だったので以後、手動にしています。

まず、質問にお答えします。

>-1, forge前提ではないmodだけは 「.minecraft」直下にあるmodsフォルダに入れるべきなのでしょうか?

→各Modのフォーラムに記載があります。(英語ですが…)
modsフォルダやcoremodsフォルダに入れるものと、
minecraft.jarに直接入れるものなど。
必ずしもmodsフォルダに入れるわけではありません。(まぁ ほとんど入れるけど)


-2, そうするとランチャーのプロフィールから起動する際の関係(保存フォルダの関係)でforge前提modと非対応modはどちらかしか選べない気がするのですが、そもそもforge前提modと非対応modというものは併用できるものなのでしょうか?

→わかりません。ただ、対応版、非対応版と両方を入れ、
併用できるできないにしろ競合したり、
エラーを起こす原因になるので入れるのはお勧めしません。
まずは対応しているmodを入れ、問題なければ次へ。が確実です。


-3, 現行環境においての1.53利用ということですが、この場合でもmodの種類によってはmodsフォルダにzipを入れるだけじゃなく1.5.3.jarを開いてmodファイルを手動で入れるという行為も当然の如くあるのでしょうか?

→1.5.2のことですよね? そうですね。modsフォルダに入れるだけじゃなく、
zipを解凍して中身を、minecraft.jarへ入れることも当然あります。
逆に、拡張子がjarのものをmodsフォルダに入れるだけのものもあります。


-4, そもそもの1.5.3forge用保存フォルダを作成した場所が 「.minecraft\1.5.3forge」じゃダメだったとかで、あるサイトに記載されてたように「1.5.3forge\.minecraft」といったように末端フォルダを .minecraftに指定しないといけなかったりするんでしょうか? その関係かMIGICLAUNCHERというツールでforgeを使用する前提での設定がうまくいきませんでした。

→う~ん…これも正直わかりません。というか、
私も1.6.2にVer.UPしマジックランチャー使いましたが、
Modを入れる過程でうまくいかなかったので、手動でやることにしました。
(その方が確実なので)


手動でのやり方を説明します。
※バックアップを取ってから、作業してください。
まず、minecraft.jarの1.5.2(バニラ)を用意してください。
探せばあるので。

用意したら、minecraft.jarをDLしたものを差し替えてください。
一度、マインクラフトを起動してバニラか確認してください。
(1.6.2新ランチャーで1.5.2は起動できたはず)

次にForgeのVer.7.8.1.738のuniversalを用意してください。
7zでminecraft.jarを開いておきます。
MATA-INFというフォルダあるので削除します。
用意したZipを解凍して中身をドラッグして、
開いたjarの中へドロップして7zを閉じます。

マイクラを起動して左下にForgeの記載あればOKです。

あとはForge対応で用意したModを、
Modsフォルダに入れて、Modの数が増えてればOKですね。

では、参考までに。

投稿日時 - 2013-10-15 19:31:30

補足

後日談ということでの補足です。
optifineのようなjarに放り込むタイプのものはMagicLauncherを用いることで解決しました。
おかげで32x32以上のテクスチャも利用できるようになり嬉しいです。

しかしながらまだ競合以外の問題でMODが利用できないなどの状況も発生してますが1つずつじっくり調べて解決していきたいと思います。

ありがとうございました。

投稿日時 - 2013-10-18 13:07:40

お礼

ありがとうございます。
1.5.2でした。いつのまにかなぜか1.5.3になってましたね申し訳ありません。

セーブデータをバックアップしたのち一度マイクラデータを削除して全て入れ直しました。その際、modsフォルダやセーブデータはバージョン別でも共通になるように、全て.minecraft直下に指定しました。

各バージョン名.jar(旧:minecraft.jar)は相変わらずversionsフォルダ下にバージョンごとにフォルダ分けされて入ってますが、それは現行ランチャーの仕様です。


ご指示のとおり手動でjar内にユニバーサル版のforgeをきっちり手順通りに入れてみたのですが、そのあとでランチャーから起動すると起動時の読込エラーが何度繰り返しても出たために、結局またjar型インストーラ版を用いました。
(※公式には1.5.2~1.6.4まではインストーラ版が用意されてます)

ランチャーから1.5.2forgeを起動すると今回も一応forgeは認識してました。

さて壁はそこからです。
ご指示のとおりに、各modの振り分け先をしっかりチェックした上で1つずつ入れてはタイトル画面に表記されてるか確認・・・を繰り返していきました。
その結果、今度はちゃんとタイトルでもmodが認識されるようになりました!
競合防止のために面倒臭がらずに1つずつ入れることは大事なんですね。
1つずつ入れて確認していくことで、競合が原因か起動できなかったり黒バックになったりしたものがいろいろ見つかりました。そういうのはきちんと排除し組み合わせてもきちんと起動できるもののみを入れていきました。

ただひとつだけ、modsフォルダやcoremodsフォルダに入れるタイプのmodは認識することが多かったのですが、バージョン名jar(minecraft.jar)に直接放り込むタイプのmod類は入れても認識しないか、あるいは起動エラーが出たりというものばかりでした。

前提としてそのjar内にはforgeが入っていてMETA-INFも削除済の状態です。そのjar内にあとから任意のmodを手動で放り込んでもうまく認識しないということなのです。
(forge入済のjarをバックアップ取って、失敗したらそれに置き換えてる)


例えばOptiFineなんかも該当します。
きちんとforgeバージョンに対応したものをDLし、
先にforgeを入れて一回起動確認したあとでoptifineを入れても起動クラッシュしてしまいます。
(他modを外した状態でやってます)

これ以外にもjarに入れるタイプのmodだけは、同じく起動エラーか起動フリーズ、及び起動できてもmodリストには表示されてないという事態ばかり。

もとのforgeも手動じゃ失敗しインストーラ型を使うはめになったので、もしかしたら現行のフォルダやファイル構築仕様が一因しているのかもしれませんね。

それはさておき、他の認識したmodはきちんとゲーム内でも反映されておりました。

さすがに一部のmodは処理が追いつかずにゲームがカクついたりなどもあったので、今度はマシンスペックの悩みもでてきました。そこは個人で解決していきたいと思ってます。

投稿日時 - 2013-10-17 04:24:02

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(1)