みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ホームページビルダーでのファイル転送について

ホームページの更新でINDEXのページからフレームで区切ったページにリンクを貼り何度転送してもフレームのあるページが“ページが見つからない”との表示が出てしまい画面に表示されずに困っています。今まで難なく更新作業をやっておりこんなことは初めてなのですが。ちなみにフレームのページを作成したのははじめてですが。もちろんバイナリーモードで転送しております。どなたか相談にのってください。お願いいたします。サーバー上の問題でしょうか。

投稿日時 - 2003-09-10 15:03:24

QNo.651532

すぐに回答ほしいです

質問者が選んだベストアンサー

遅れましたが、
一応参考までに、私の強引な解決策をご説明しておきます。
フレームHTMLタグ
の部分で、

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta name="GENERATOR" content="IBM WebSphere Homepage Builder V6.0.1 for Windows">
<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">
<meta http-equiv="Content-Style-Type" content="text/css">
<title></title>
</head>
<frameset cols="100,*" frameborder="NO" border="0">
<frame src="左のページをアップしたURL">
<frame src="右のページをアップしたURL">
<noframes>
<body>
<p>このページを表示するには、フレームをサポートしているブラウザが必要です。</p>
</body>
</noframes>
</frameset>
</html>

という感じにします。
タグのページで「保存」をし、
閉じようとすると、「変更点を訂正しますか」といわれますので、
ここでは「いいえ」とします。
(タグを保存したあと、さらに訂正点がなければ、です。
ここで「はい」にすると、チェックが入り、訂正されてしまいます。
タグ表示でないページには、「表示できません」と出ますが、
プレビューを見ると、ごらんいただけます。その状態でOKです)

これで解決しているのですが・・・ただ、リンクの処理に多少面倒がありますね・・・この方法ですと・・・

投稿日時 - 2003-09-13 07:59:19

お礼

ご丁寧なご回答を何度もありがとうございました。
うまくいきました。感謝いたしております。お返事が遅れまして申し訳ございませんでした。

投稿日時 - 2003-09-17 10:44:25

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.5

ツールバーの「ページ転送」ボタンではなく,「サイト転送」ボタンをクリックして,転送をしてみてください。

投稿日時 - 2003-09-12 02:36:35

ANo.4

フレームのあるページがありますよね?
これをAとしましょう。
その中の、左のページを1、右のページを2とします。
1のページも、2のページも、
それぞれ単独のページとして編集でき、
これもそれぞれアップしなければいけません。
(これはFTPをご利用であれば、右の欄に上げられていれば、アップされている、と判断できます)
ここで、Aのページをもう一度開き、
アップされた1のページのURLを左に、
2のページを右に、
それぞれ表示するように指定します。
(#2の方のタグでよかったと思います)

その上で、Aもアップすると、
WEB上で、左に1のページが、右に2のページが表示される、という事やったと思います。

今日実際調べてみますので、違うようなら補足しますね。

投稿日時 - 2003-09-10 21:11:56

ANo.3

ファイル転送画面の右側にフレームのファイルがありますか?

サイト転送を使ってはどうでしょうか?

投稿日時 - 2003-09-10 15:26:51

お礼

早速のアドバイスをありがとうございました。急いでいたわりには事情がありまして、その場を離れてしまったのです。友人のコンピュータだったもので。残念ながら続きは1週間後になってしまうのですが、今、冷静になって考えてみますとフレームページを作成時に左のフレームを先に作成し、右はフレーム内に開くという作業をしないで
カーソルを動かし普通に作成してしまいました。もちろん左・右・合わせたものの3つ個別に名前を付けて保存は行ったのですが。それが原因と考えられますか?
 。転送作業はツールバーのこのページを転送するという作業のみで行っております。ファイル転送画面の右側にフレームのページはあります。

投稿日時 - 2003-09-10 16:35:38

ANo.2

フレーム内でアドレスを見てみてください。間違っていませんか?
<FRAME name="http://○○.htm">

投稿日時 - 2003-09-10 15:12:25

お礼

早速のアドバイスをありがとうございました。急いでいたわりには事情がありまして、その場を離れてしまったのです。友人のコンピュータだったもので。残念ながら続きは1週間後になってしまうのですが、今、冷静になって考えてみますとフレームページを作成時に左のフレームを先に作成し、右はフレーム内に開くという作業をしないで
カーソルを動かし普通に作成してしまいました。もちろん左・右・合わせたものの3つ個別に名前を付けて保存は行ったのですが。それが原因と考えられますか?
 。転送作業はツールバーのこのページを転送するという作業のみで行っております。

投稿日時 - 2003-09-10 16:32:11

ANo.1

もしかして、フリースペースにアップされたはりますか?
私も同じ症状なので、以下のように処理しています。

いったん、フレームページの、右と左のソースのリンク先を、それぞれをアップしたアドレス名にして、
そのまま保存、
訂正しますか?のコマンドにいいえ、と答え、
そのままフレームのHTMLをアップしてみてください。
これでとりあえずは表示されるはずです。

ほんまは正しい方法があるのでしょうが・・・はい。

投稿日時 - 2003-09-10 15:09:32

お礼

早速のアドバイスをありがとうございました。急いでいたわりには事情がありまして、その場を離れてしまったのです。友人のコンピュータだったもので。残念ながら続きは1週間後になってしまうのですが、今、冷静になって考えてみますとフレームページを作成時に左のフレームを先に作成し、右はフレーム内に開くという作業をしないで
カーソルを動かし普通に作成してしまいました。もちろん左・右・合わせたものの3つ個別に名前を付けて保存は行ったのですが。それが原因と考えられますか?
 申しわけないのですがアドバイスをいただきました右のフレームにいったん、フレームページの、右と左のソースのリンク先を、それぞれをアップしたアドレス名にして、とおっしゃる意味がわかりません。まだまだ素人ですね。転送作業はツールバーのこのページを転送するという作業のみで行っております。

投稿日時 - 2003-09-10 16:25:24

あなたにオススメの質問