みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

無線LANでファイル共有とネットワークプリントが出来ません

いつもお世話になっております。
先日、無線LAN内蔵のノートPC(FMV-BIVLO LOOX C/E50L:以下PC3と記載)を購入しましたが、無線LAN接続でファイル共有とネットワークプリントが出来ません。(有線接続では問題ありません。)
折角無線LAN内蔵PCを買ったのに、有効に活用できず困っております。どなたか解決方法をご教示願います。

機器構成
ルータ BUFFALO WZR2-G300N IPアドレス192.168.11.1
PC1 Win7デスクトップ 有線LAN接続 IPアドレス自動取得
PC2 WinXPデスクトップ 有線LAN接続 IPアドレス自動取得
PC3 Win7ノートブック 基本は無線LANで接続 IPアドレス自動取得
プリンタ EPSON PM-A870 PA-W11G2にて有線LAN接続 IPアドレス192.168.11.128で固定
※PC3のみ、無線LAN接続

今の状態
1.PC1~3からルータ(192.168.11.1)宛pingは正常
2.PC1からPC2・プリンタへのpingも正常
3.PC2からPC1へのpingも正常
4.PC3からルータ宛pingも正常に通ります。(有線・無線LAN接続の両方で)
5.PC3からPC1・2へのpingは、有線LAN接続の時のみ通り、無線LAN接続の場合NG
6.PC1・2からPC3へのpingは、有線LAN接続の時のみ通り、無線LAN接続の場合NG
7.PC1・2からプリンタへの出力は正常に出来ます。(双方向通信も出来ています)
8.PC3からのプリンタ出力は、PC3を有線LAN接続しているときは正常に出来ます。しかし、無線LAN接続下ではNG
9.PC1・2間ではファイル共有出来ています。
10.PC3は、有線LAN接続の時のみファイル共有できます。無線LANではネットワークに参加できません。
11.ルータの「プライバシーセパレータ」ON/OFFでは無いようです。
12.PC3でのホームページ閲覧・メール送受信は、有線・無線共に正常に出来ます。ルータの設定画面も開けます。
13.Windowsファイアーウォール無効・ウイルス対策ソフト(ウイルスセキュリティ)無効の状態で試してみても変わりはありませんでした。
※PC3を無線LAN接続にした時のみファイル共有とネットワークプリントが出来ない状態です。有線LAN接続下の場合では特に問題はありません。

無線LANのときのみの症状なので、プリンタの設定間違いやPCのプリンタ関連設定の間違いではないとは思います。
ルータの設定か、PC3のネットワーク関連の設定に問題があるように思っていますが、解決方法が見つからない状態です。

何卒よろしくお願いいたします。

投稿日時 - 2009-11-14 22:32:44

QNo.5448341

すぐに回答ほしいです

質問者が選んだベストアンサー

BUFFALOのWZR2-G300Nルーターを使用していまして、
似たような症状が発生しておりました。
ファームウェアが2010年1月7日にバージョンアップしまして、
そちらを導入すると、症状が解消されました。

もし、同じ原因でしたら症状が回復する可能性があります。

参考URL: http://buffalo.jp/download/driver/lan/wzr2-g300n_fw-win.html

投稿日時 - 2010-01-08 23:35:11

お礼

ご回答ありがとうございます。
早速ファームアップしたところ、見事に解決いたしました。
年末バッファローに問い合わせをしたところ、「ルータ側の問題ではない」といった旨の回答があったのですが、やはりルータ側の問題だったのですね。
非常に助かりました。本当にありがとうございました。

投稿日時 - 2010-01-09 01:29:05

ANo.3

このQ&Aは役に立ちましたか?

6人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

もしかしてPC3の「ファイルとプリンターの共有を無効にする」がONになっていませんか?
添付ファイルの[ネットワークと共有センター]-[共有の詳細設定の変更]-[ファイルとプリンターの共有を有効/無効にする]

投稿日時 - 2009-11-26 15:10:16

お礼

ご回答ありがとうございます。
「ファイルとプリンターの共有を無効にする」はOFFでした。
実は、先日ルータをWBR-G54に変えてみたところ、今まで出来なかったファイル共有が何の問題もなく出来るようになりました。
他に、ロジテックの無線アクセスポイントを使ってみたりもしましたが、こちらでもOKでした。
どうやら、WZR2-G300Nのほうに何か原因があるようです。
もしくは、「相性問題」なのかもしれません。(だとしたら、これ以上どうしようもないことになってしまいますが・・・ちなみに、ファームウェアを更新しても変化ありませんでした。)
何とかWZR2-G300Nを使いたいと思っているので、自分でももう少し調べてみたいと思っています。
改めまして、ご回答ありがとうございました。

投稿日時 - 2009-11-26 16:25:29

ANo.1

もしかしてPC3がWEPで接続されていませんか?

WEPはセキュリティレベルが低いため、WEP子機から他の機器に接続できないようにする機能がWZR2-G300Nには付いています。
発生している現象から類推すると、「PC3がWEPで接続されていて」、「WEP子機から他の機器に接続できないようにする機能が有効になっている」としか思えないのですが。

色々試されているようなので、まるっきり外している可能性は高いですが、一度確認されてみてはいかがでしょうか。

投稿日時 - 2009-11-15 04:48:00

お礼

ご回答ありがとうございます。
早速、ご指摘の点について確認をしてみました。

問題のPCは
・セキュリティの種類:WPA2-PSK
・無線の種類:802.11n
で接続しています。
また、ルータの設定で「WEP専用SSID隔離」を「無効」にしておりました。

今回のケースでは、ご指摘の点に関しては特に問題は無いように思えます。しかし、当初暗号化の種類についてはチェックしていなかったので、ご回答は大変参考になりました。
本当にありがとうございます。

投稿日時 - 2009-11-15 22:35:33

あなたにオススメの質問