みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ルーターとメール送信

以前にもここで同様の質問をして一旦は解決したと思ったのですが、また問題が発生したので、質問させていただきます。

状況:
これまでフレッツ接続ツールを使ってきましたが、もう1台あるPCからも同時に接続できるようにするために、最近からルーターを介してADSLモデムにつないでインターネットに接続するようにしました。ところが、それ以来メールの送信ができなくなりました。
ルーターを外して直接ADSLモデムにつなぐと、問題なく送信できます。

メーカーのホームページをみると最新のファームウエアでは、「メール送信に時間がかかる問題を解決した」とあったので、ファームウエアをアップデートしてみたのですが、それでも完全には解決しませんでした。
数行程度のメール送信はできるようになったので、効果はあったのかもしれませんが…依然として大きなサイズのメール送信ができません。(…といっても数KB程度でもダメで話になりません。添付ファイル付メールがダメなのはいうまでもありません。)

今の状態が続くと、メールを送信するたびにADSLモデムに直接つないで、フレッツ接続ツールで接続しなおす…という実に面倒な作業をしなければなりません。

何か解決策をご存知の方よろしくお願いします。

※数種類のメールソフトで試しましたが、結果は同じでした。
※メールの受信は、ファイルサイズに関係なく実行できます。
※インターネットへの接続自体は全く問題ありません。
※もう一つのPC(WindowsXP)からはファイルサイズの大きなメールも問題なく送信できます。

OS:Windows98
回線:フレッツADSL1.5M
ルーター:CR110 (Century Systems)
PC機種:e-one433 (SOTEC)

投稿日時 - 2003-05-02 13:04:27

QNo.537397

すぐに回答ほしいです

質問者が選んだベストアンサー

以前回答したものです。
http://www.okweb.ne.jp/kotaeru.php3?q=532606

>数行程度のメール送信はできるようになったので、効果はあったのかもしれませんが…
>
ということなので、やはりPMTUDが問題になっているのでかな?
とりあえず、ここを参考にMTUの設定を変えてみてはどうでしょうか?
http://member.nifty.ne.jp/oso/faq/mtu-faq.html#needs

参考URL:http://member.nifty.ne.jp/oso/faq/mtu-faq.html#needs

投稿日時 - 2003-05-02 17:40:21

お礼

回答ありがとうございます。

結局ウイルスバスターのファイアウォール設定を「低」にするか無効にするかで、解決することが出来ました。
フレッツ接続ツールを使っていたころは、ウイルスバスターのファイアウォールは何の問題も起こさなかったので、全く頭が回らなかったのですが、ふと思いついてセキュリティレベルを変更してみると成功しました。
これまでデフォルトで問題がなかったのに、ルーターを付けただけで何故送信できなくなるのかは分かりませんが・・・
実際職場のPCでは同じようにルーターを介して接続し、ウイルスバスターのデフォルト設定で全く問題は起きていません。

少し古いルーターが影響したのか、e-oneのLANアダプターに問題があるのか、複数の要因が重なって起きたのでしょうかね・・・。

MTUやPMTUDブラックホール問題についての説明は読ませていただき、とても勉強になりました。
さしあたり問題なくメールもFTPも使えるようになりましたが、
また今後も問題が発生するようならこちらの方の設定変更にも挑戦することになると思います。

たびたび回答をいただきましたこと、重ねてお礼申し上げます。

投稿日時 - 2003-05-06 12:00:20

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(7)

ANo.7

AI1

NO.3の方が言われていますようにMTUの設定を変えてみてはどうでしょうか下記ホームページを参考にされたらよいと思います。
<ブロードバンドルーターを使用すると数行程度の容量の小さなメールしか送信できません。 ブロードバンドルーターを使用して容量の小さなメールしか送信できない場合、MTU、RWINという値を変更していただく必要(PMTUDブラックホール問題の為)がございます。>

MTU、RWINの変更方法
http://www.fiberbit.net/member/faq/faq_10_4.html
参考URLはPMTUDブラックホール問題の解説です

参考URL:http://www.fiberbit.net/member/trouble/trouble_2_4.html

投稿日時 - 2003-05-04 10:36:06

お礼

回答ありがとうございました。
皆様のおかげで無事に解決することが出来ました。

投稿日時 - 2003-05-06 14:00:37

ANo.6

ウイルス対策ソフトがインストールされていると、
メールフィルタ機能が働く事があります。
かといって、送信用のフィルタもあるかどうかは
分かりませんが・・・

NAT機能がうまく働いていないのかなぁ・・・

一応、気持ち悪いくらいに安定しているDHCP・DNS・ルータ機能のある商品を参考URLに載せます。
(安定しているからといって、なんでやねんと
 つっこむのもどうかと思って、つっこみしてませんが・・・・)

参考URL:http://www.ntt-me.co.jp/mn128/slotin.html

投稿日時 - 2003-05-03 13:42:49

お礼

回答ありがとうございました。
ウイルスバスターが問題だったようですが、メール検索機能ではなくファイアウォールの設定で対処できました。
別のルーターにすればデフォルトのままでも送信ができるのかどうかは分かりませんが、当面はこれで乗り切るつもりです。
ファイアウォールのセキュリティが「低」でも、ルーターを介しているので滅多なことはないと思うので・・・

投稿日時 - 2003-05-06 14:00:07

ANo.5

AI1

※もう一つのPC(WindowsXP)からはファイルサイズの大きなメールも問題なく送信できます。との事ですが
そのLAN(PC(WindowsXP)が接続してある)ポートに問題のPCを接続して試して見られました?
それで上手くいかなければPC側の問題になりますが、今のままですとブロードバンドルーター側に問題があるのかPC側なのかわかりません

投稿日時 - 2003-05-02 17:45:25

補足

回答ありがとうございます。
全てのポートを試してみましたが、結果は同じでした。
つまり、XP機で問題なく送信できているポートでもダメでした。
やはり、PC側の問題になるのでしょうか…

投稿日時 - 2003-05-02 22:12:39

ANo.4

LANアダプタは最初から増設してあったものでしょうか?
コントロールパネルからシステムのプロパティを開いて
デバイスマネージャーを選んでネットワークアダプタを確認しましょう。XXXEthenetXXAdapterのところに表示されるメーカーや型番を調べて該当メーカーのサイトからドライバーをDLしてきます。DLしたファイルの中のREADMEにやりかたが書いてあると思いますので確認して更新してみてください。

重要な更新がないと書いてあったので、IE6SP1をお使いですね。それならば、IE5.5SP2に戻してみると案外解決が早いかもしれません。いくつかのパッチの再適用は必要になるかもしれません。ドライバ更新の前に試してみてください。Win98の頃のデバイスとIE6とで上手く整合しない部分があるのかもしれません。我が家のWin98SEはIE6と反りが合いませんでした。参考まで

投稿日時 - 2003-05-02 17:45:09

お礼

回答ありがとうございました。
無事に解決しました。
ウイルスバスターのファイアウォールが主因だったようです。
もっとも、何故ルーターを介したくらいで結果がここまで違うのか分からないので、いまいちスッキリしませんが・・・。

ちなみに、e-oneには最初からLANポートがついていて、BIOSでオンにすると、デバイスマネージャでLANアダプタが認識されるようになっています。
ドライバーはサイトで調べても新しいのがなかったので、更新はできませんでした。
PCカード用のLANカードでも買って試してみれば、違う結果になるのでしょうかね・・・。
ネットワーク関連の知識が甘く皆様にご迷惑をおかけしたので、今後はもう少し勉強しようと思います。

投稿日時 - 2003-05-06 13:53:55

ANo.2

LANアダプタのドライバを更新してみてはいかがでしょう
XP機に問題がないのなら、双方で異なるものといえばOSやドライバあたりでしょう。WindowsUpdateも最新パッチを適用済みですよね?

投稿日時 - 2003-05-02 13:18:12

補足

LANアダプタのドライバの更新はどのようにすれば良いのでしょうか?
Windows Updateで先ほど確認したところ、重要な更新とドライバの更新はなかったようです。
(ただ、ルーターを介すようになってからWindows Updateのスキャンにもやたらと時間がかかるようになってしまいましたが…)

投稿日時 - 2003-05-02 13:43:34

ANo.1

どうみても、これはPC側の問題ですよね。
「フレッツ接続ツール」は、PPPoEのツールなので、もしまだインストール
されたままなら、アンインストールされた方がいいと思います。
はずしてるかな?

投稿日時 - 2003-05-02 13:13:07

補足

フレッツ接続ツールをアンインストールしてWindowsを再起動しましたが、まだ解決できません。
アンインストールをしてもレジストリの変更などがのこったままということなのでしょうか?

投稿日時 - 2003-05-02 13:41:54

お礼

回答ありがとうございました。
無事に解決することが出来ました。

投稿日時 - 2003-05-06 12:00:50

あなたにオススメの質問