みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

「OS XのClassic環境」と「OS 9での起動」の違い

こんにちは。
勉強不足で申し訳ありませんが、今必死に学んでいますのでお願いします。

「OS XのClassic環境」と「OS 9での起動」の違いがよく理解できません。
(100GのハードにOSが2つ入っています)
動きも違うようですし、OS9のみ対応しているソフトは「OS 9での起動」を
した状態でインストールするのでしょうか?
また、OS XとOS 9両方に対応しているソフトはOS X で起動している時にインストール
すれば、「OS X」、「OS XのClassic環境」、「OS 9での起動」いずれの状態でも
問題なく動作するのでしょうか?

いよいよ、Macが本格的にOSXのみでの起動ということで、慌ててOS XとOS 9両方
起動できるG4 1.25Gデュアルを購入しました。
DTPの仕事をしており、当面はOS 9での作業をメインとし、OSXに慣れておこうと
思っております。(タイミングとしては、QuarkExpressの問題、OpenType
フォントの普及で移行かなと考えています。)
ソフトとフォントは、QuarkExpress4.1、Illustrator8.0、Photoshop5.0、
ATM4.6、ATM用モリサワNEW-CIDフォントです。

投稿日時 - 2003-04-22 22:51:35

QNo.529637

困ってます

質問者が選んだベストアンサー

>OS9のみ対応しているソフトは「OS 9での起動」を
した状態でインストールするのでしょうか?

Classic環境でインストールできる物が多いですがおかしくなる場合もありますのでできればOS 9で起動してインストールを行った方が無難です。

>OS XとOS 9両方に対応しているソフトはOS X で起動している時にインストールすれば、「OS X」、「OS XのClassic環境」、「OS 9での起動」いずれの状態でも
問題なく動作するのでしょうか?

OS XおよびOS 9対応のソフトの場合OS X上ではOS Xで動きますのでClassic環境は起動(利用)しません。OS 9で起動していたら同じアプリケーションがそのまま動きます。
両方で動く物にはAppleWorksなどがありますが.appという拡張子がついています。

Classic環境はいわゆる互換のための物でOS X上でOS 9を動かすという物であって読み込む機能拡張などや動作などは違ってきますのであくまでもClassic環境と考えた方が無難です。

>ソフトとフォントは、QuarkExpress4.1、Illustrator8.0、Photoshop5.0、

これは大変ですね。OS X用に使おうと思ったらソフトとフォントは、QuarkExpress6、Illustrator10.0、Photoshop7.0、とそろえることになりますね。お金がかかりますねー。

ちなみにクォークをOS X上で動かしたときの問題点が参考URLにあります。

参考URL:http://www.quark.co.jp/techdb/db_150.html

投稿日時 - 2003-04-22 23:04:48

補足

asucaさんいつも丁寧に回答いただき本当にありがとうございます。

>OS XおよびOS 9対応のソフトの場合OS X上では~~~あくまでもClassic環境と考えた方が無難です。
「OS X」、「OS XのClassic環境」、「OS 9での起動」の3つの状態理解できました。

>OS X用に使おうと思ったらソフトとフォントは、QuarkExpress6、Illustrator10.0、Photoshop7.0、
とそろえることになりますね。
そうなんですよ。ですから当面はOS9のドライブを作り、これらのアプリケーションはそこに入れて
おこうと思っています。

モリサワのATM用NEW-CIDフォントは、「OS9のドライブ」にインストールするのが、
問題ないとは思うのですが、
参考までに、これを「OSXドライブ」のライブラリーのフォントにインストールする手はありますか?
「OS9のドライブ」にATMをインストールすれば、フォントをこのOSXのライブラリーフォントの中まで
見にいってくれて、ちゃんと動作してくれるか疑問です。
また、OSXではやはりOpenTypeフォントしかだめなんでしょうか?

いつもながら、またまた質問ですいませんが、よろしくお願いします。

投稿日時 - 2003-04-23 13:47:06

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.5

>「OSX」「OSXのClassic」「OS9」で使用するには、フォントはAに入れないといけないということですよね。

OS Xで起動しているときはo S9(Classic環境用)にインストールされたフォントはシステムに反映されないのでOS Xのフォントフォルダにインストールする必要があります。
逆にOS 9で起動したときは当然OS XにインストールしたフォントはOS 9では反映されません。ですからそれぞれにインストールしておく必要がありますね。

当然ですが起動しているディスク上のフォントしか反映されません

>ただ、別ドライブにあるフォントまでちゃんと管理してくれるか心配です。

残念ながらそこまでうまくはやってくれないようです。

投稿日時 - 2003-04-25 02:58:47

お礼

asucaさん、最後の最後まで親切に回答いただき、なんとお礼を言ってよいのやら。
「OSX」「OSXのClassic」「OS9」の3つ、特に後者2つを混同している方って、
実は多いんじゃないかと個人的に思います。OSXより以前のOS環境=Classicみたいな。
今回、本当によく理解できました。ありがとうございます。

別の質問でasucaさんに教授いただいたやり方でやったつもりですが、一部問題が発生してしまいました。
たぶん私のやり方に問題があるんだと思うんですが、よろしかったら、フォローお願いいたします。
質問No.531873

投稿日時 - 2003-04-25 18:14:40

ANo.4

>なんだか、「OSX」や「OSXのClassic」ではインストールできないけど、動作はするってことですよね

そうですね。動作保証はしてないということですね。OS X対応と銘打った物で何と何か問題があっても知らないよという感じです。

実際に使っていますが問題は何もないです。
メーカが保証してくれないだけで実質てきにも問題はないです。

>アドバイス通り、「OS9」ドライブを作成してそこにインストールすれば、別ドライブの「OSX」や「OSXのClassic」でも動作するよなので、これが一番ですね。

別ドライブ?起動時に読み込まれなければフォントとして認識されませんので起動しているパーティション上もしくはClassic環境で使うのだったらClassic環境上にフォントがインストールされている必要があります。
ですからOS 9用のパーティションにインストールしていてうまくいっていてもOS Xで起動し直したときはOS XのClassic環境用のOS 9の所にフォントがインストールされていないと使えないことになります。
システム環境設定のClassic設定でインストールしたOS 9のパーティションをClassicの起動ディスクで指定すれば何とかなるのですが。


つまりシステムはOS Xのフォントとして、もしくはClassic環境が起動していてしかもその環境用にインストールされてるフォントしか認識しませんので。

投稿日時 - 2003-04-24 06:11:52

補足

すいません。また疑問となってしまいました。
内蔵ドライブをA:OS XおよびClassic用OS9領域 、 B:OS 9用、C:メンテナンス用 XおよびOS9、 D:データ用にフォーマットするとして。

「OSX」「OSXのClassic」「OS9」で使用するには、フォントはAに入れないといけないということですよね。
BにATMを入れておけば、Bで起動してもフォントは大丈夫でしょか?
ATMはシステムフォルダのフォントに入れておかなくても、フォントがある場所を
管理して、使用と不使用を選べるんですよね。ただ、別ドライブにあるフォントまで
ちゃんと管理してくれるか心配です。

投稿日時 - 2003-04-24 13:30:47

お礼

>別ドライブ?起動時に読み込まれなければフォントとして認識されませんので
>起動しているパーティション上もしくはClassic環境で使うのだったらClassic環境上に
>フォントがインストールされている必要があります。
なるほど、よく理解できました。本当にわかりやすい説明ありがとうございます。

投稿日時 - 2003-04-24 13:29:19

ANo.3

>新しく質問「No.530368」でお願いしました。よろしかったら、こちらの方も覗いてください

はい、見てしっかり答えています。がんばってくださいね。

>MorisawaのNew CIDはどうなんでしょう?


参考URLの方法を確認してください。

参考URL:http://www.morisawa.co.jp/news/support/mac_osx102j.html

投稿日時 - 2003-04-23 23:47:36

お礼

asucaさん、本当になんとお礼を言ってよいのやら。
参考URLも実は回答いただく直前に拝見したのですが、これまた大誤算でした。
私の記憶ではOSX=OpenTypeでしたが、どうやらOS10.2以降ならNewCIDも大丈夫になっていたみたいです。

ただ、MORISAWAのサイトの説明もちょっとわかりにくいです。なんだか、「OSX」や「OSXのClassic」では
インストールできないけど、動作はするってことですよね。
アドバイス通り、「OS9」ドライブを作成してそこにインストールすれば、
別ドライブの「OSX」や「OSXのClassic」でも動作するよなので、これが一番ですね。

いかにクリーンな「OS9ドライブ」を作るかに集中したいと思います。

投稿日時 - 2003-04-24 01:56:10

ANo.2

>モリサワのATM用NEW-CIDフォントは、「OS9のドライブ」にインストールするのが、問題ないとは思うのですが、

もちろん全く問題はないですね。

>参考までに、これを「OSXドライブ」のライブラリーのフォントにインストールする手はありますか?

参考URLを参照してください。

参考URL:http://www.fontworks.co.jp/support_taiou_osx101.html

投稿日時 - 2003-04-23 15:58:59

補足

フォントについては、一応「OS9のドライブ」にインストールすることにしようと思います。

ここへ来て大きな問題に当たってしまいました。その「OS9のドライブ」を作るのって
簡単じゃないんですね。落とし穴でした。
てっきり、OS XのレストアCDが何枚かと、OS9のレストアCDが何枚かだと思っていたら違いました。
過去ログに同様の質問があったので、拝見しましたが一部新しい疑問があるので、
新しく質問「No.530368」でお願いしました。よろしかったら、こちらの方も覗いてください。
おんぶにだっこですいません。

投稿日時 - 2003-04-23 21:26:55

お礼

参考URL拝見しましたが、ちょっとよく理解できませんでした。
同じCIDフォントでも「OSX」「OS Classic」「OS 9」それぞれ動作の状況が違うんですね。
それにCDか、FD+CDか、などのインストールの問題もあるみたいですね。
MorisawaのNew CIDはどうなんでしょう?
そもそもATMフォントは、ATMが動いてなんぼのものだから、
やはりOS Xでは使用できないと考えた方がいいのかもしれません。
asucaさんがおっしゃる通り、「OS9のドライブ」にインストールするのが、問題ないですね。

投稿日時 - 2003-04-23 21:20:48

あなたにオススメの質問