みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Shockwave Flash Object (.swf) のファイルが表示できない

こんばんわ。お世話になります。
僕は自分で漫画を描いて、サイトでFLASHをホームページに張り付けて漫画を公開しています。少し以前からFLASHのページを開くと「マクロメディアより、最新版のFlashプレイヤーを手に入れてください。」と表示され、閲覧することができなくなりました。最新版のFlashのインストールや一度アンインストールしてからのインストール、ショックウェーブのインストールなど試したのですが、ダメでした。他のパソコンなどでも閲覧を試みたのですが、同じような現象がでます。解決策がありましたら教えて下さい。お願いいたします。

そのFlashをインストールした先のURLはこちらです。
(作成した管理人は音信不通です。)
http://www.ctime.jp/WebComicReader/

僕の漫画を公開しているページの一部の直リンクはこちらです。
http://www.gyogyo-tail.net/entory6/entory6.htm

Flashのファイルの種類は、Shockwave Flash Object (.swf)です。
使用してるパソコンはVistaです。
ブラウザはInternet Explorer7です。

投稿日時 - 2008-12-31 01:56:08

QNo.4594571

困ってます

質問者が選んだベストアンサー

Flash Player 9 で閲覧すると無事に表示されましたが,
Flash Player 10 で閲覧すると確かに
「マクロメディアより、最新のFlashプレイヤーを手に入れてください。」
と出ますね。


原因はだいたい推測できます。
これはたまにあるんですよ。
おそらくFlash(SWF)内部に
「Flash Player 7 以上でなければ上の表示を出す」
というActionScriptのプログラムが書かれてあると思うのです。

簡単に言うと,
Flash Playerのバージョンの桁がFlash Player 10 になることによって2桁になったでしょう。
もし下1桁でバージョンを判断していれば
 バージョン10=バージョン0
と判断されるんです。

「Flash Player 10 バージョン判別チェックリスト」
http://www.adobe.com/jp/devnet/flashplayer/articles/ver_check_flp10.html

これは基本的にFlashの作者でしか直せません。
つまりユーザーからはどうすることもできません。
(Flashができればなんとかできなくもありませんが普通はできないと思います。)


しかし,
「マクロメディアより、最新のFlashプレイヤーを手に入れてください。」
の表示は Flash内のフレーム1(アニメの1コマ目)にだけあって,
漫画コンテンツはフレーム2以降に用意されているようです。

とりあえずユーザー側からできることは,
「マクロメディアより、最新のFlashプレイヤーを手に入れてください。」
の表示画面で
画面を右クリック→再生
でフレーム2を表示させることでしょうね。

作者の人と連絡をとれるまでは,
応急処置として,
『「マクロメディアより、最新のFlashプレイヤーを手に入れてください。」
 という表示が出た場合は 右クリック→再生 を選択してください。』
というようなメッセージをその漫画ページを開く前にでも書いておくことでしょうか。

投稿日時 - 2008-12-31 05:55:17

補足

詳しくご回答していただきありがとうございます。
「右クリック→再生」で、漫画を閲覧することはできました。

しかし、できれば「Flash Player 7 以上でなければ上の表示を出す」
というActionScriptのプログラムを修正したいと思うのですが、何か必要なソフト、また高度な知識が必要なのでしょうか?

作者との音信が不通なので、できれば自分で直したいと思うのですが、プログラムの知識はありませんが、直すことは可能でしょうか?

投稿日時 - 2008-12-31 09:18:43

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

XPSP2 IE6では閲覧可能です。
最新版のFlashのインストールの際に、Windowsファイアーウォールのブロックやセキュリティ対策ソフトのパーソナルファイアーウォール機能の遮断がありませんか?
または、IE7のセキュリティ設定でブロックはありませんか?(例:「ツール」「インターネットオプション」「セキュリティ」「レベルのカスタマイズ」「セキュリティの設定」ActivXコントロールやスプリプトを「有効」に、「ツール」「インターネットオプション」「全般」「Cookieの削除」「ファイルの削除」「OK」や「セキュリティの設定」「ダウンロード」「ファイルのダウンロード」「有効にする」、レベルを「中高」から「中」に落としてみるなど)
その他一時的に「検索ツール」をアンインストール(後で再インストールする)

投稿日時 - 2008-12-31 06:06:17

補足

おはようございます。
朝早くから、ご回答ありがとうございます。

投稿日時 - 2008-12-31 09:18:01

あなたにオススメの質問