みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

HDDが認識しなくなりました。

再インストールしたらHDDが認識しなくなりました。

環境
M/B:BIOSTAR TA690G AM2
OS :WinXP SP2
HDD1:S-ATA接続500GB(C/Dドライブに割り当て)
HDD2:IDE接続80GB(Eドライブに割り当て。データ専用ドライブ)
HDD3:IDE接続250GB(Fドライブに割り当て。データ専用ドライブ)

この状態でOSが起動しなくったので、IDE接続の80GBにとりあえずの仮OSを入れて、
S-ATAドライブのバックアップを実施。
こっちの仮OSで起動すれば問題なく全部のドライブを認識している。

で、調子の悪くなったS-ATAの500GBをフォーマットして新OSを入れ直したら、
IDE接続のHDD2とHDD3が認識できなくなった。
・BIOS上では正常に認識されている。
・BIOSの設定は調子が悪くなる前からいじっていない。
・OSはすべて同じWiXP SP2
・仮OS側で起動すればデバイスマネージャーで全ドライブを認識している。
・新OSで起動してデバイスマネージャーを確認してもS-ATAドライブ1つしか認識されていない。
・新OSのインストールとドライバのインストールなどの初期設定終了までは、
 邪魔になるのでIDEドライブの電源を抜いていた。

一通りの初期設定終了後に接続したら認識しなくなりました。

単純にOSを入れ直しただけだと思っているんだけど、何が原因なの?
IDEドライブのデータは待避済みなのでフォーマットするのとかはOKです。
何も設定を変えていないのに、新OSでデバイス自体を認識してくれません。
どうすればIDEドライブを認識するようになりますか?

投稿日時 - 2008-08-21 00:10:12

QNo.4266281

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

ANo.1

こんにちは。

 特にえらーが出ずにwindowsが起動していて、
なお、デバイスドライバーに?が出ていないのなら。

スタート>コントロールパネル>管理ツール>コンピュータの管理を選択してください。
左項目の「ディスクの管理」をクリックします。

 そこにディスク2、ディスク3にディスクがありますか?。
あるのでしたら、オンラインになっていますか?。
おそらくは以前の80GBと250GBがdiskC,Dドライブの
名前となっており、今回はすでにC,Dが存在するために
マウントされていないと想像しています。
 disk欄の右クリックからプロパティでドライブを開いている
FとかGとかを割り当てると使えるかと思います。

投稿日時 - 2008-08-22 00:17:04

お礼

せっかく回答していただいたのにごめんなさい。
自己解決しました。
hulun001さんの回答でも改善可能なパターンもあると思いますが、
今回私の環境で起きていたこととは違いました。

デバイスマネージャのIDE ATA/ATAPIコントローラでIDEチャネルをすべて無効にしていました。
Windowsデフォルトでは自動になっています。
この項目を無効にしておくとパフォーマンスがあがるので、いつもOSインストール後に真っ先にOFFにしています。

今回はこれが原因で、HDDを認識させる前にOFFにしたため追加出来なくなってしまったようです。
これを自動にしたところ問題なく認識できました。

お騒がせしまして、申し訳ありませんでした。

投稿日時 - 2008-08-22 20:04:13

あなたにオススメの質問