みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

HUBを通すとネットワークが利用できなくなってしまいます

少し前からスイッチングHUBを通すとネットワークに接続できなくなってしまいました。

HUBを通さず、ADSLモデム・他のPCに直接LANケーブルを接続すると通常通りインターネットにも接続できますし、共有フォルダも参照できるのですが、HUBを通した場合ネットワーク周りが一切利用できなくなってしまいます。pingすら通りません。

他のPCからはHUBを通してもインターネットに接続できるためこのPCのみおかしいのかと思い、オンボードのLANをやめLANボードを増設してみたり、HUBが壊れたのかと思いHUBを新たに購入してみたりしたのですが相変わらず接続できないままです。

現状では、

・直接接続した場合はネットワークが利用できるため、LANボードやケーブルに異常はない
・他のPCからはHUBを通してもインターネットに接続できるためHUBには異常はない
・他PCとXBOX360が同時にインターネットに接続できるためADSLモデムには異常はない
・IPアドレスやコンピュータ名の重複もなし

と認識していますが、となると何がおかしいのかさっぱりわからず・・・。

環境は以下の通りです。

PC       ショップブランドのCore2Duo機
OS       WindowsXP SP2
LANボード    玄人志向 Gbe-PCI2
スイッチングHUB BUFFALO LSW3-GT-8NS
ADSLモデム    NEC Aterm WD606CV

ADSLモデムの設定で素人目に関係ありそうな項目を挙げてみると、PPPoA接続、NATモードは通常動作、UPnP有効になっています。

WindowsXPなりLANボードやADSLモデムの設定なりで何かこのような状況になることはありますでしょうか。何でも結構ですので情報頂ければと思います。よろしくお願いします。

投稿日時 - 2008-08-01 22:21:04

QNo.4221083

暇なときに回答ください

質問者が選んだベストアンサー

オンボードのLAN IFはギガ対応のものではないでしょうか?

だとすると、
・玄人志向 Gbe-PCI2→ギガ対応
・BUFFALO LSW3-GT-8NS→ギガ対応
・NEC Aterm WD606CV→100Mbps対応
ということなので、直接つないだときはギガでネゴシエーションを失敗して通信できなくなっているような気がします

(1) LANケーブルを1000BASE-T対応とうたっているもの(エンハンストカテゴリ5)に変える
(2) PC側で速度の設定ができるなら、100Mbpsに落としてみる
(3) もし100MbpsのHUBがあればそれとLSW3-GT-8NSを入れ替えてみる

のどれかで通信できるようになると思います

投稿日時 - 2008-08-02 09:04:38

お礼

ご回答頂きありがとうございます。
確かにオンボードのLANはギガビット対応のものです。

ケーブルは買いにいかないと手に入らないため、まず速度設定の件を試してみることにしました。

まず昔の100MbpsのHUBにPCと他PC、ADSLモデムを接続し、LANボードのドライバの設定で速度を10Mbpsにしてみたところどちらもしっかりとネットワークが確立されました。
その後速度を上げてみたところ100Mbps半二重でも接続できた(全二重だとpingでたまにロスが発生)のですが、HUBを新しいものに変更してみたところ接続できませんでした。

どの機器も壊れておらず、設定によるネゴシエーションの失敗が今回の原因だとして、HUBはLSW3-GT-8NSのまま試しにオンボードのLANに戻してみたところ、ジャンボフレームを使用しなければ接続速度がオートでも無事接続されるようになりました。

結局、設定を上のものに合わせていれば機器に応じて自動で切り替えてくれるものだと勝手に思い込んでいたことが今回のトラブルの原因だったようです。
対応速度の違う複数の機器が存在する場合は、設定を任せず速度の低いものに合わせた設定を行う方が良さそうですね。

私の思い込みでviolet430様、774danger様にはご迷惑をおかけしてしまい申し訳ありませんでした。ご助言頂けなければ未だにHUBを使わないまま使用していたと思います。本当にありがとうございました。

投稿日時 - 2008-08-02 15:08:19

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

他のPCで上手くいくようですが、全く同じ条件で比較していますか?
接続ポートは同じですか?
同時に接続したパソコンの起動順などは?

投稿日時 - 2008-08-02 06:43:30

お礼

ご回答頂きありがとうございます。

ポートに関しては、他PCで接続できたポートに接続してみたり、すべてのポートに接続してみたりしましたが状況は変わりませんでした。

パソコンの起動順については自PCが常用マシンなため、常に先に起動しています。ただ、ネットワークの設定を変更した場合などは念のために自PCを落としたこともあるため、その場合は他PCの方が先になるかと思いますが、状況は変わりませんでした。

投稿日時 - 2008-08-02 13:13:27

あなたにオススメの質問