みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

eclipseを使ったphpの開発環境について

今、仕事でphpをすることになり、eclipseで開発環境を整えようとしているのですが、
うまくいきません。

流れとしては、
1.xamppをインストール
 バージョンは、xampp-1.6.3a です。
2.Eclipse(all-in-one)のインストール
 バージョンは、pdt-all-in-one-1.0-R20070917 です。
3.ZendDebuggerをインストール
ZendDebugger-5.2.10-cygwin_nt-i386をダウンロードし、
バージョンにあった、ZendDebugger.dll を
 C:\xampp\php\ext にインストール。
4.php.ini の書き換え。
 C:\xampp\apache\bin\php.ini 内の[Zend]の項に、
 zend_extension_ts="C:\xampp\php\ext\ZendDebugger.dll"
zend_debugger.allow_hosts=127.0.0.1
zend_debugger.expose_remotely=always
 を追加で書き込み。

この一連の流れでやったところ、apacheすら立ち上がらなくなりました。

いろいろ触ってみて、[Zend]の項で、
 zend_extension_ts="C:\xampp\php\ext\ZendDebugger.dll"
zend_debugger.allow_hosts=127.0.0.1
zend_debugger.expose_remotely=always
以外の部分に、すべて;をつけてみたところ、
eclipse自体は立ち上がったのですが、
こんどは、デバッグしようとすると、
エラーでまったくデバッグできないような状況です。

php.iniの書き換えを間違ってるような気がするのですが、
あまりそこについての情報がなく、困ってます。
どなたか教えてください。
よろしくお願い致します。

投稿日時 - 2007-12-06 12:42:22

QNo.3575468

困ってます

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

こちらのサイトの手順通りにやったらできましたよ。

http://php7.web.fc2.com/

Eclipseの代わりにAptana Studioを使った方法が載っていますが、Eclipseでもほぼ同様の手順でできました。

参考URL:http://php7.web.fc2.com/

投稿日時 - 2012-12-05 15:53:54

ANo.1

Xampp+AllinOneであれば、ZendDebuggerは、ZendDebugger-5.2.3-Windows-i386を使う形かと思います。

私は、3.以降で
ZendDebugger-5.2.3-Windows-i386,zipを展開、
中のフォルダから、「5_2_x_comp」フォルダを「5_2_x」にリネーム、
C:\xampp\php\zendOptimizer\lib\Debugger以下にこのフォルダをコピーし、
php.iniにて、
zend_extension_manager.debug_server_ts = "C:\xampp\php\zendOptimizer\lib\Debugger"
と設定することで、動作しました。

ご参考までに。

投稿日時 - 2007-12-06 14:07:01

あなたにオススメの質問