みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

「不適切な MFC Dll バージョンがシステムにインストールされています。最低限 MFC SP4 Dll が必要です。」

こんにちは。
PCを起動したら、このようなエラーが出ました。
(ようこそ画面でパソコンから「ピー」という電子音がなりました)


ワイヤレス構成
不適切な MFC Dll バージョンがシステムにインストールされています。最低限 MFC SP4 Dll が必要です。


何度「OK」を押しても、再び出てきます。
出ないようにする方法がございましたら、ご教授よろしくお願い申し上げます。

投稿日時 - 2007-11-12 16:32:51

QNo.3511746

すぐに回答ほしいです

質問者が選んだベストアンサー

MFCのバージョンがダウンしていますね。
最近ではほとんど発生しなくなったインストーラの強制上書きの可能性が高いです。

例えばVC2.0の頃のソフトとかはVC6.0とかは意識していないというか
VCが出始めた古い時代は新しいものの可能性も全然考慮していないので、
古いソフトのインストーラを使うとこういうことが発生します。
VC4.0ぐらいの時でも、できの悪いVCインストーラを使うとこうなります(被害経験あり)

ワイヤレス構成というからには無線LANですか?
まともに動いていない可能性もありますから以下のURLを参考に
根本から直した方がいいでしょう。

http://www.iris.dti.ne.jp/~ys-kondo/karude/bmpng.html

その他のウィルス感染とかの可能性は#1の方に準じます。
心当たりがあるのならこちらの検査が一番先ですね。

投稿日時 - 2007-11-12 18:30:41

お礼

こんばんは。アドバイスありがとうございました。
セーフモードで起動して、「chkdsk」をかけたところ、エラーが発生しなくなりました。
また何かありましたら、どうぞよろしくお願い申し上げます。

投稿日時 - 2007-11-13 18:06:55

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

mfc.dllはVC++をプログラミングする時に使うDLLファイルだったはず。

こいつがエラーするということは、何かバージョン違いの不正なVC++
プログラムが動作しているということです。最近何か「出本の怪しい」
フリーソフトをインストールしませんでした?

心当たりが無ければ、ウイルス(ボット)感染を疑ったほうが良いです。

投稿日時 - 2007-11-12 16:58:33

お礼

こんばんは。アドバイスありがとうございました。
セーフモードで起動して、「chkdsk」をかけたところ、エラーが発生しなくなりました。
また何かありましたら、どうぞよろしくお願い申し上げます。

投稿日時 - 2007-11-13 18:07:14

あなたにオススメの質問