みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

XoopsCubeのインストール失敗に関して

XOOPS CUBEのインストールのデータの生成時にエラーになります。
エラーメッセージは
Warning: Invalid argument supplied for foreach() in
C:\webprograming\apache\Apache2\htdocs\stoops\install\index.php on line 1223

Warning: Cannot modify header information -
headers already sent by (output started at
C:\webprograming\apache\Apache2\htdocs\stoops\install\index.php:1223) in C:\webprograming\apache\Apache2\htdocs\stoops\install\index.php on line 1231

5個のデータをデータベースxoops_ranksにインサートすることに失敗しました。
14個のデータをデータベースxoops_smilesにインサートすることに失敗しました。
3個のデータをデータベースxoops_groupsにインサートすることに失敗しました。
2個のデータをデータベースxoops_groups_users_linkにインサートすることに失敗しました。
55個のデータをデータベースxoops_group_permissionにインサートすることに失敗しました。
3個のデータをデータベースxoops_bannerにインサートすることに失敗しました。
1個のデータをデータベースxoops_modulesにインサートすることに失敗しました。
11個のデータをデータベースxoops_newblocksにインサートすることに失敗しました。
11個のデータをデータベースxoops_tplfileにインサートすることに失敗しました。
11個のデータをデータベースxoops_tplsourceにインサートすることに失敗しました。
5個のデータをデータベースxoops_configにインサートすることに失敗しました。
となってしまいます。

環境は
WindowsXP Pro(SP2)
Aptche Ver2.0.55
PHP Ver5.0.5
Mysql Ver5.0.15
です。

Mysqlのコマンドで確認したところテーブルは全て
作成されています

解決につながる情報をお持ちの方いらっしゃいましたら
ご教授、お願いいたします。

投稿日時 - 2005-11-07 19:57:27

QNo.1764080

困ってます

質問者が選んだベストアンサー

現在の推奨環境は以下のとおりです。
PHPの5はたぶん問題ないと思いますが、MySQLの5だというのが
問題なのではないでしょうか。

* WWWサーバ: Apacheを特にお薦めします
* データベース: MySQL4.0.xx(将来的にはPostgreSQL等にも対応予定)
* PHP: PHP4.1.0 以降 (4.3.11を推奨~標準パッケージでは、PHP5.0.xに対応していますが、一般に配布されているモジュールには未対応のものもあります)

Cubeの公式サイトのほうが解決早いと思いますよ。
http://xoopscube.jp/index.php

投稿日時 - 2005-11-07 23:35:33

お礼

回答、ありがとうございます。
おっしゃるとおりでした。
MySQLのバージョンを落としたところ無事にXoospの
インストールも成功いたしました。
OSXでは大丈夫だったのでてっきり他に原因があったのかと・・・

公式サイトも見たのですが10月末に他の方が同じ
質問をしており、返信がなかったので、こちらに質問してみました。

どうもありがとうございました。

投稿日時 - 2005-11-08 23:50:08

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問