みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

ADSLでHUBを使うと接続できません

ADSLで複数台接続をしようと思っています。
PCは、Win95とWin98。
プロバイダはニフティ。ADSLはイーアクセスです。

今日、Win95で接続を試してみました。
ADSLモデムとPCを直接ストレートケーブルで繋ぐと
ちゃんと接続できるのですが、間にHUBを介すと、接続できません。
ADSLモデム→クロスケーブル→HUB→ストレートケーブル→PC(Win95)

Winpcfgで確認したところ、HUBを介した場合は、IPアドレスが
0.0.0.0になっていました。
「更新」を行うと、「DHCPサーバが利用できません」と出てしまいます。

どうしたら接続できるようになるのでしょうか。
よろしくお願いいたします!

投稿日時 - 2001-10-15 23:43:39

QNo.151830

暇なときに回答ください

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

ここで言うADSLモデムは多分MegabitGeer TE4111Cでしょう。
まず、ADSLモデム→クロスケーブル→HUBの場合、HUBの通常ポートに接続しましょう。
多分これが原因です。
TE4111C自体は初期状態でDHCPサーバ機能はONになっています。

一度マニュアルに従ってADSLモデムをリセットした状態で再設定してください。

# HUBの種類によっては相性があって接続が悪いようです、、、

投稿日時 - 2001-10-16 10:26:29

お礼

まとめてレスをします!
結局いろいろ試してダメだったので、メーカーに問い合わせたところ、

『HUBの初期不良』

ということが判明いたしました。お騒がせして、申し訳ありませんでした!
今日交換してもらうので、それで改善されると思います。
どうもありがとうございました!

投稿日時 - 2001-10-26 10:55:11

ANo.5

ルータの設定は大抵の場合ブラウザから
http://ルータのLAN側のIPアドレス
で設定画面に行けると思います。細かい事はマニュアル見ないとわかりません。

DHCPを使わないなら、PC側の自動取得をやめて適当なIPアドレス(192.168.1.100とか・・)を割り当ててあげればいいでしょう。

投稿日時 - 2001-10-16 10:04:29

ANo.4

ハブから上位(ADSLモデム)につながるケーブルはきちんとUplinkポートに接続されていますか?
PC側はどのポートでも構いませんが、上位に繋がるケーブルだけは特定のポート(たいていは一番端のポートでUplink等何らかの記述があるはず)に接続しなければなりません。

あと考えられるのは、PCのネットワーク設定。
DHCP等を利用する設定になっているでしょうか?

またADSLモデムにDHCP機能をON/OFFする設定があれば、これはONになっていますか?

(LAN側に静的にアドレスを振られているのであれば上の限りではありません。)

投稿日時 - 2001-10-16 00:57:23

補足

ケーブルは大丈夫です。

ADSLモデムのDHCP機能のON/OFFの設定の仕方は、
どうやったらできるのでしょうか?

かなりの初心者なため、さっぱりわかりません。
よろしくお願いいたします。

投稿日時 - 2001-10-16 01:01:16

ANo.3

ルータのDHCPサーバー機能はONになっていますか?
PC側はのIPアドレスの自動取得になっていますか?

設定はこれぐらいだと思うのですが・・・。

投稿日時 - 2001-10-16 00:55:09

補足

ルータのDHCPサーバー機能のON/OFFは、
どうやったら変えられるのでしょうか?
どこで確認できるのかがわかりません…。

投稿日時 - 2001-10-16 01:00:16

ANo.2

>プロバイダはニフティ。ADSLはイーアクセスです。

 私も同じ条件ですが、複数台接続できています。

>ADSLモデム→クロスケーブル→HUB→ストレートケーブル→PC(Win95)

 HUBの機種や設定によっては、モデムとの接続はクロスケーブルではなくてストレートケーブルを使います。私のHUB(Corega HUB5PL)ではストレートケーブルです。

 もう一度、HUBの取扱説明書をよく見て確認してください。

 HUBの機種の中には、モデムにつながるポートがクロスかストレートか切り替えるスイッチがあります。このスイッチを入れれば、クロスケーブルのまま使えます。

投稿日時 - 2001-10-16 00:00:07

補足

PCIのスイッチングHUBを使っているのですが、
ケーブルが間違っていると思い、
クロスとストレート両方で試してみましたが、
やっぱりだめでした。

ちなみに、私のHUBだと、uplinkポートに挿す場合はストレートケーブル、
普通の1-5ポートに挿す場合はクロスケーブルを使用するみたいです。
ポートを変えたり、ケーブルを変えたりしてみたのですが、
やはりうまく行きません。

投稿日時 - 2001-10-16 00:38:40

ANo.1

HUBを使う場合は、プロバイダからIPアドレスを2つもらっていることが前提となります。またはADSLモデムがルータ機能を内蔵している場合に、プライベートのIPをそれぞれのPCに割り当てる設定をすれば可能です。

現状はどういう設定になっているのでしょう?

投稿日時 - 2001-10-15 23:55:57

補足

ご回答ありがとうございます。

モデムはルータタイプです。
よろしくお願いいたします。

投稿日時 - 2001-10-16 00:37:51

あなたにオススメの質問