みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

LANケーブル認識不良

ADSL(8MB e-access ルーター付きモデム)からCATV(30MB J-COM ルーター機能無し MOTOROLA SB5100)に回線を変更しました。ADSLではWinXP(SOTEC PV2270AR)機とWin98機でインターネット接続を共有するために、10BASE/TのHUB(アライドテレシス MR815T)を介してLANを接続していて、そのままの接続ならば問題なくインターネットに接続できます(ルーターが無くなったので同時接続はできません)。ところが、回線速度を速くするためにCATVモデムからWinXP機に直接LANケーブルを接続したところ、「ネットワークケーブルが接続されていません」のメッセージが出てLANケーブルを認識してくれません(ケーブル接続のランプも消灯します)。なぜかHUBを間に入れるとネットワークを認識して、インターネット、メールが正常に使えますが、回線速度が5MBしかでません(ケーブル接続のランプは点灯しています)。使用しているケーブルは、エレコムのストレートケーブル カテゴリー5eです。
 SOTECとJ-COMに連絡して、モデム-HUB間、HUB-PC間のケーブルを差し替えたり、モデム、PCとも電源を抜いて数時間放置したり、PCのBIOSをデフォルトに戻したり、LANカード(SiS 900-Based Fast Ethernet Adapter)のドライバをセーフモードで初期化してから再インストールしたりしましたが、やはり、直接接続の時はエラーメッセージ、HUBを介するとケーブルを認識します。
 ケーブルは新規に買ってきたり、もとからあるものも線の色を確認して、すべてストレートであることを確認しています。また、どのケーブルを使っても、直接はだめで、HUB中継だと接続できるので、ケーブルの断線はないと思います。

 SOTECからは、すべてを初期化するためにリカバリーするように連絡をもらっているので、今までにたまったデータのバックアップをとっているところですが、できれば他の方法で解決できないかと質問させていただきます。

投稿日時 - 2005-05-05 17:12:21

QNo.1369468

すぐに回答ほしいです

質問者が選んだベストアンサー

パソコン内蔵のLANアダプタ(SiS900-Based Fast Ethernet Adapter)の自動認識(Auto-Negotiation)機能がちゃんと働いていないような気もします…。
パソコンメーカーの用意したドライバではなく、LANアダプタに搭載されているチップメーカー(SiS)が配布しているリファレンスドライバを使ってみてはどうでしょう?
(万が一の事を考えて、大事なデータをバックアップし終わっていることが前提です)

●SiS ダウンロードページ
 ( http://www.sis.com/download/ )
 英語表記ですが、STEP BY STEPで「Network Driver」→「SiS900 & Integrated SiS LAN~」→「Windows XP」と選択していって「[→]GO」と押して次のページで「[→DOWNLOAD NOW]」をクリックして「sl118.zip」をダウンロードしてみて、それを使ってみると変化があるかもしれません…

後は、LANアダプタのプロパティで、通信方式を自動認識(Auto-Negotiiation)から100M半二重(100BASE-TX/Half-Duplex)に固定にさせているのも良いのかも。

それでもダメだと、CATVモデムとLANアダプタとの相性になると思うので、可能であればLANアダプタ(LANボード?)を変更してみる事を検討してみてはどうでしょう?
最近市販されているLANアダプタはほとんどがRealtek等を採用していてSiSを使っていないので、相性問題が回避できるかもしれません。

投稿日時 - 2005-05-06 10:28:34

補足

ご回答、ありがとうございます。
 LANアダプタのドライバ、助言に従ってバージョンアップしてみましたが、それだけでは、やはり認識しませんでした。
 次に、通信方式を変えてみたところ、自動認識、100BASE/TX(全二重、半二重)、10BASE/T(全二重)は認識しませんが、10BASE/T(半二重)にするとLANケーブルを認識して、インターネット、メールも問題なく使えます。LANアダプタとモデムの認証がうまくいっていないのは確かなようですが、なぜでしょうか?この状態だと、ネットに接続は出来るものの、CATVに回線を変えた意味はありません。どなたか解決策をお持ちでしたら、教えてください。

 直接接続でもつながるモードが出てきたので、CATVプロバイダ、SOTECにもう一度問い合わせをしてみます。また、アドバイスをいただいたように、LANアダプタの変更も考えてみます。

投稿日時 - 2005-05-08 14:20:37

お礼

 SOTECに問い合わせたところ、引き取り修理を提案されたのですが、1週間も預かるとのことで、困っていました。
 提案をいただいたように、LANボードを買ってきて付けたところ、そのボードから接続すると問題なくAuto-Negotiationで接続し、25MB以上が簡単に得られました。
 やはり、PCのLANボードが問題だったようです。

投稿日時 - 2005-05-16 23:04:59

ANo.5

このQ&Aは役に立ちましたか?

3人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.4

モデムとPCの双方のLANカードが10/100Mの自動切替のタイプなのでは
そして双方の自動認識がうまく行かない状況

もうひとつの可能性は、HUBを入れる場合といれない場合では、クロスもしくはストレートのLANケーブルを使い分ける必要がある

投稿日時 - 2005-05-05 21:05:39

お礼

ご回答、ありがとうございます。
自動認識が働いていないのは確かなようです。
もう少し試してみます。

投稿日時 - 2005-05-08 14:19:55

ANo.3

そもそも8Mの契約で5Mだったら、そんなに遅くないと思いますが。直接つなぐことでどれくらいの速度アップを望んでいらっしゃるのでしょうか? ご存知だとは思いますが、8Mと言うのは、ベストエフォートと言い、電話局からの距離が一番大きな速度低下の要因となると思うのですが。
すべて初期化してのリカバリーはものすごく大変な作業だと思いますよ。とりあえず、HUBを1000BASEのものに買い換えてみるのはどうですか? あとで家庭内ネットワークを構築するときにも、有効だし。

投稿日時 - 2005-05-05 17:31:01

補足

ご回答ありがとうございます。
質問の書き方が悪かったようで、誤解を招いてすみません。
8MBのADSLの時は4MB程度の速度で満足していましたが、30MBのCATVに回線を変更したのに、10BASE/TのHUBを通すことで5MBしかでないので、困っているわけです。ネットの書き込みなど見ると、CATVの30MB契約なら、20MB以上は出るはずなので、その速度を実現したいと思っています。
先の回答者の方の補足に書きましたが、100MBpsのHUBを使っても、LANケーブルを認識してくれません。
追々は、ブロードバンドルーターを使って家庭内ネットワークを構築するつもりなので、とりあえずは直接接続でLANケーブルを認識して、ネットへの接続ができるようにしたいのですが。

投稿日時 - 2005-05-05 20:45:53

ANo.2

何だか、色々行うより、ボトムネックになってる10BASE/TのHUB(アライドテレシス MR815T)を早いもの(100Mbpsの)に交換した方がいい解決方法な気もしますが・・・。

投稿日時 - 2005-05-05 17:22:57

補足

ご回答ありがとうございます。
ややこしくなるので書かなかったのですが、回線を変更した際に、HUBも100Mbps対応のもの(Laneed LD-PSW08N/AT)に変更したのですが、それだと、直接接続と同じようにLANケーブルを認識しないのです。
 HUBの接続方式に違いがあるのでしょうか?素人なもので、よく分かりません。

投稿日時 - 2005-05-05 20:41:39

ANo.1

LANケーブルには、ストレートケーブルとクロスケーブルがあります。
 ハブ無しでの接続は、通常クロスケーブルでの接続になります。
 ADSLモデムに、ストレートとクロスの切り替えがありませんか。なければケーブルの買い換えが必要かと思います。

投稿日時 - 2005-05-05 17:19:43

補足

ご回答、ありがとうございます。
CATVモデムの接続ガイドには、必ずストレートケーブルを使うようにとの指示があります。
PC同士の接続ではないので、ストレートで良いのではないかと思っているのですが。

投稿日時 - 2005-05-05 20:36:46

あなたにオススメの質問