みんなの「教えて(疑問・質問)」にみんなで「答える」Q&Aコミュニティ

こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

USB2.0をUSB1.0/1.1と認識する問題

私のPCにはUSBのポートが8個ついていますが、どうやら1つ以外、USB1.0/1.1と認識しているようです。

デバイスマネージャをみると

USB universal Host Controller *4
USB2 Enhanced  Host Controller *1
USB ルートハブ *5

が表示されています。

USB universal Host Controller *4 のドライバは
usbhub.sys
usbport.sys
usbuhci.sys
usbui.dll
の4つですが
USB2 Enhanced  Host Controller *1のドライバは
上記の4つに加え
hccoin.dll
というドライバが入っています。
またUSBルートハブのドライバは
usbd.sys
usbhub.sys
となっています。

どうすれば、すべてUSB2.0と認識するようになるでしょうか?
OSはWin XP Pro SP1a で、マザーボードはAopen i915Pa-Eを使用しています。

投稿日時 - 2005-03-22 19:57:00

QNo.1284892

すぐに回答ほしいです

質問者が選んだベストアンサー

それで正常です。
通常Enhanced Host Controllerは1個しかありませんが、全てのポートがUSB2.0で動作します。

USBポート2個に付きコントローラーが1個なので、8ポートでUSB universal Host Controllerが4個、それに対し全てのポートをUSB2.0として動作可能にするためにEnhanced Host Controllerが1個あります。

投稿日時 - 2005-03-22 20:03:12

お礼

正常だったのですね(汗

接続してみたところ速度が遅いので異常だと思っていました。

どうもありがとうございました。

投稿日時 - 2005-03-22 21:55:25

ANo.1

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

th9

調べてみましたが、このHDDはUSB1.1でした。

http://www.logitec.co.jp/products/hd/lhde60su.html

>結局のところこの機器をUSB2.0ポートに接続しても速度は変わらないということですよね?

そうです。
どちらかが1.1だと、遅い方に合わせて動きます。

このHDDの速度を早くしたいなら、SCSIボードを増設してそちらに繋ぐ必要があります。

http://www.logitec.co.jp/products/if/lha600s.html

http://www.logitec.co.jp/products/henkan/lubsc2.html

または、USB2.0対応の外付けHDDケースを購入して、そちらに中身を移し変える方法もあります。

投稿日時 - 2005-03-23 19:50:36

ANo.5

#2です。

>PCのポートがUSB2.0に対応してても、接続する機器がUSB2.0に対応していないとだめなのでしょうか?
>それとも接続する機器にはそのような規格はないのでしょうか?


USBメモリーの1部の機種では、USB1.1の機種が有りますが、最近の外付けドライブは100%と言って良いほどUSB2.0対応製品ですので、99%はUSB2.0で動くと思っていただいて良いですよ。

それに、対応製品には必ず「USB2.0対応」と言う表示がどこかに記載されていますから、それを確認して各種機材を購入されたら良いと思います。

>接続してみたところ速度が遅いので異常だと思っていました。


実際の転送速度をHDDの規格で言い換えると、ATA66のHDDのスピードに近いです。
つまり、理論上は毎秒約50MBの転送速度になりますが、実際のスピードは毎秒約30MB前後になるようですね。

最近のHDDのほとんどはATA100(毎秒100MB)かシリアルATA(毎秒150MB)と言う転送速度ですから、ご質問のように遅く感じますが、それでもUSB1.1のスピードに比べたら約33倍以上のスピードになるんですよ。

後は、#4さんの解答を合わせて参考にして下さい。

投稿日時 - 2005-03-22 23:50:16

お礼

接続機器を購入したのではなく、PCを新しくしたもので、速度がUPすると期待しておりました。
アドバイスどうもありがとうございます。

投稿日時 - 2005-03-23 18:39:34

ANo.4

th9

>接続してみたところ速度が遅いので異常だと思っていました。

接続した機器のメーカー名と型名は分かりますか?

USBポートが2.0でも、接続する機器が1.1なら1.1で動作します。
また途中に1.1のハブがあると、そこから先の機器は全て1.1で動作します。

http://e-words.jp/w/USB201.1.html

またWindows XPはデフォルトでは、1.1のUSBポートに2.0の機器を繋いだり、2.0のUSBポートに1.1のハブを繋ぐとバルーンヘルプで警告が出ます。

投稿日時 - 2005-03-22 23:04:11

お礼

接続している機器はLogitecの外付けHDD LHD-E60SUです。
かなり昔の機器ですのでUSB2.0対応にはなっていないと思うのですが、XPを使っていても警告はでないです。
結局のところこの機器をUSB2.0ポートに接続しても速度は変わらないということですよね?

投稿日時 - 2005-03-23 18:37:37

ANo.3

>PCのポートがUSB2.0に対応してても、接続する機器がUSB2.0に対応していないとだめなのでしょうか?
たしかHUBで1.1用と2.0用があったはずです。
試した事はありませんが、
おそらく使えるかもしれませんが、
2.0用でない分、遅いと思われます。

投稿日時 - 2005-03-22 22:06:46

お礼

アドバイスどうもありがとうございます。

投稿日時 - 2005-03-23 18:32:57

ANo.2

現在の状態で、全てのポートがUSB2.0として認識されていますから大丈夫ですよ。

私の自作パソコンのデバイスマネージャーでも同じように表示されていますが、どのポートも問題なくUSB2.0として動作しています。

投稿日時 - 2005-03-22 20:43:06

補足

1つ気になることがあるのですが、PCのポートがUSB2.0に対応してても、接続する機器がUSB2.0に対応していないとだめなのでしょうか?
それとも接続する機器にはそのような規格はないのでしょうか?

投稿日時 - 2005-03-22 21:56:15

お礼

大丈夫のようで安心しました。

どうもありがとうございました。

投稿日時 - 2005-03-22 21:56:08

あなたにオススメの質問